Lineup Signup
Hi! We're just rearranging some Desktop boards to make it easier to find what you're looking for. Please bear with us, and we'll be done very soon.
To post a new question or issue, please go here: Desktop (Windows), Desktop (Mac), Desktop (Linux), Web Player.

Spotify Connect on Onkyo receiver problems

Reply
4 people liked this

Spotify Connect on Onkyo receiver problems

earvenj
Casual Listener

Plan

Premium

Country

Netherlands

Device

Samsung Galaxy S7 Edge, Nokia 7 Plus

Operating System

Android

 

My Question or Issue

Quite often when I stream something from one of my two Android phones to my Onkyo receiver with Spotify Connect, the song's sound is on-and-off for like 10-30 seconds, or the sound is gone completely for minutes. Meanwhile, on my phone in the Spotify app, the Onkyo app as well as in the receiver's display it says the song is still playing. It also responds to pause/play/skip, but the sound remains gone. 

 

Sometimes after a while (10-30 seconds) it picks up and the music plays fine for hours from that point, but sometimes it doesn't pick up and the only solution then is to restart the receiver while the song is still streaming from my phone.

 

It also often happens that the song's sound is gone for a while shortly after adjusting the volume, either on my phone or on the receiver's own volume knob. 

 

I think it's not a network problem: the receiver has a cable to my router, Netflix and internet radio are playing fine. Also, streaming to my Sonos speakers via Spotify Connect is never a problem. I have a very stable network with good coverage (Ubiquiti router and 3 Ubiquiti APs).

 

To me it seems like a receiver problem, but before I return the unit, I'd like your expert opinion on this :) 

 

Thanks!

7 Replies
2 people liked this

Re: Spotify Connect on Onkyo receiver problems

GeertVE
Casual Listener

I have exactly the same problem.  I use iPhone7/iPad2017/iOS12. onkyo TX-L20D.

Spotify Connect, and AirPlay have same problems.

network reset, amplifier reset, wired/wireless (networkstrength is 85% and up), tried all

 

Problem occured after updating software.

 

B4 returning the Onkyo, all tips are welcome

 

Geert

3 people liked this

Re: Spotify Connect on Onkyo receiver problems

kikan
Casual Listener

I have the same problems ! Onkyo TX-NR676 / iPhone and Android phone. I changed my internet & WiFi router, I changed all my Ethernet cables to high end shielded ones, still no change (never used the Onkyo on WiFi).

Please Spotify help us! 

2 people liked this

Re: Spotify Connect on Onkyo receiver problems

taoizt
Newbie

Here very similar problem.  Onkyo TX-NR676 / Android phone and Ipad in use. Before I had Spotify Connect option for Onkyo receiver when i started Spotify. Now suddenly this option has disappeared. Tried restarting modem/router, and setting up Spotify in screen menu when choosing 'NET - Spotify', but interface gets stuck at 'connecting........' forever.

Have been using it daily for almost a year without problem, now suddenly i can't use Spotify anymore on Receiver....pfff

2 people liked this

Re: Spotify Connect on Onkyo receiver problems

kikan
Casual Listener

Did you unplugged the amplifier from AC and then replugged it after a couple of minutes ?

 

if not, do that, kill and restart Spotify app on your Android and iPad, and it should work again (with the same problems we had but better than what you described).

 

also are you still on a premium account ?

Re: Spotify Connect on Onkyo receiver problems

baun
Newbie

Did anyone figure this out?  I've been using my onkyo for a while now with spotify connect and just today my receiver shows up as "Google Cast" in my Spotify app.  When I tap it to connect it just says "connecting..." forever.

Re: Spotify Connect on Onkyo receiver problems

RomanMedv
Newbie

Same issue here on Onkyo 575.

Seems like an Onkyo issue, did anyone started a thread with Onkyo support as well?

Re: Spotify Connect on Onkyo receiver problems

earvenj
Casual Listener

Thanks for your reply, but I tried all the things you mention. 

I did not yet start a thread with Onkyo support; I "solved" it by attaching a Chromecast Audio dongle :)

SUGGESTED POSTS