Announcements

Spotify Web Player Has No Sound with Firefox Quantum

Reply
Highlighted

Spotify Web Player Has No Sound with Firefox Quantum

Casual Listener

When using Spotify Web Player on Firefox Quantum (57.0) 64-bit on Windows 7, music appears to play but has no sound output. Yes I tried the volume and connections and the Mixer, and checked the Web Player volume. All other sounds work and output just fine (Windows notifications, Pandora, etc.), just not Spotify.

3 Replies
Highlighted

Re: Spotify Web Player Has No Sound with Firefox Quantum

Rock Star 17
Rock Star 17

Hey @thewrightstuff

 

It might be this kind of problem arising from cache or cookies, so I recommend wiping them. You don't really have to delete all the cookies, just Spotify ones should be sufficient.

Try the web player in the 'safe mode' - go to Help - Restart with addons disabled. If it plays that way, then there's something up with some of your addons. 🙂

 

Let me know how you get on!

SebastyRock Star 17
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
Highlighted

Re: Spotify Web Player Has No Sound with Firefox Quantum

Casual Listener

Thanks, but clearing cookies had no effect on this issue. I also restarted Firefox Quantum in safe mode with add-ons disabled and cookies cleared and the issue persisted. For kicks and giggles, I also checked the Windows "Volume Mixer" but that was fine and not the issue either. I never had this problem before Firefox upgraded to Quantum. I'm currently running v57.0.1 (64-bit).

Highlighted

Re: Spotify Web Player Has No Sound with Firefox Quantum

Casual Listener

I just figured out the issue and am surprised at the cause. After logging in and viewing the web player, I noticed the "connect a device" icon was illuminated green. When I clicked on it, the text said "Listening On Web Player (Chrome)". I thought, that's strange, why would it say that when I'm on Firefox? And then noticed right above that, illuminated white was the text "This Web Browser Spotify Connect", so I selected that. Then the Chrome text turned white and "This Web Browser..." turned green. For some reason beyond me, it had selected my Chrome browser to play music and defaulted to that, even after clearing cookies and restarting Firefox in safe mode with add-ons disabled! Oh well glad I figured it out, thanks again for trying to help.

SUGGESTED POSTS