Announcements

Spotify in Firefox Doesn't work

Solved!
Reply
Highlighted

Re: Spotify in Firefox Doesn't work

Regular

Sadly, It's already set to always activate.
I have tried about 20 different things over the last 24 hours.
I honestly think something in latest Firefox broke the webplayer.

Highlighted

Re: Spotify in Firefox Doesn't work

Regular

If you could find out what codex it was, that would be beneficial.

 

Highlighted

Re: Spotify in Firefox Doesn't work

Regular

Play DRM Content is checked.

 

Solution!

Re: Spotify in Firefox Doesn't work

Regular

One thing I have that MIGHT be causing problem, but shouldn't
about:config
media.autoplay.enabled is set to FALSE

The reason this is set to this is to stop hundreds of websites that autoplay videos when you open their page (CNN is a big one that does it, but many others)
All this flag does it make it so you have to click on play button first before media content will play.
So all that should happen is when I click on a song, it should still play if I hit the play button.
But Spotify is not regonizing the play button as activation.

 

View solution in original post

Highlighted

Re: Spotify in Firefox Doesn't work

Music Fan

I found what I did to make it work. I used the yast 1 click install from this guide.

Highlighted
Solution!

Re: Spotify in Firefox Doesn't work

Regular

In Firefox, if the about:config flag "media.autoplay.enabled" is set to false
then the spotify webplayer will NEVER work.
This flag is important to stop nasty web sites that bombard users with videos or ad-videos the user has no control over.
Please allow the web player to work correctly with this flag set to false.
I would have no problem with the music playing once I click play, but this flag stops a-hole sites that load a video without waiting for user to click play.

View solution in original post

Highlighted

Re: Spotify in Firefox Doesn't work

Newbie

I am on Fedora 27 running Firefox 57

I just had to install the ffmpeg-libs package and Spotify Web Player was working just fine.

$ sudo dnf install ffmpeg-libs
Highlighted

Re: Spotify in Firefox Doesn't work

Regular

Type in URL bar: about:config
What is your "media.autoplay.enabled" flag?
I'm betting it's set to true.
However, due to so many **bleep** websites adding auto play videos and autoplay ads that blast the user without their consent, most people change that flag to False.
The way it's SUPPOSED to work, is the user has to hit the PLAY button videos etc. for the media to play.
For some reason, the spotify webplayer is not accepting the play button as activation.
WIth this flag at true, the player works.
But, myself and many others refuse to have this flag on true because of stated above reasons.
Chrome has a similiar flag, (they call it "user gesture) but because of their ad network and revenue, it doesn't work on most sites anyway because crappy sites found a loophole around Chromes implemention.
I refuse to go back to using a web that Chrome decides for me.

Highlighted

Re: Spotify in Firefox Doesn't work

Newbie

It worked!!! Thanks.

Highlighted

Re: Spotify in Firefox Doesn't work

Casual Listener
I'm running Ubuntu 16.04, Firefox 57.0.1 64 bit. Encountered the same issue. Steps I took to fix this issue: 1. enable widevine. 2. install VLC media player. 3. run sudo apt-get update. VLC seems to install some necessary dependencies for open.spotify to run properly.
SUGGESTED POSTS