Unfortunately DRM is not enabled

Reply
Highlighted

Re: Unfortunately DRM is not enabled

Casual Listener

Weirdly, I have found that using this script:

 

https://gist.github.com/ruario/3c873d43eb20553d5014bd4d29fe37f1

 

I can get Spotify to work in Vivaldi 1.11.917.17-1. However using the exact same Widevine shared object (libwidevinecdm.so) in Chromium 59.0.3071.109 (Ubuntu 16.04), I get the familiar error message, "Playback of protected content is not enabled". Vivaldi, like Chromium, uses Blink.

Highlighted

Re: Unfortunately DRM is not enabled

Regular

@leptitchriss wrote:

@antonillo-s wrote:

You are using an unsupported system configuration. Firefox 52.x is relative new supporting DRM.

 


I'm not too sure what you are talking about, Firefox is on the supported list of browsers...

 


A little of history from wikipedia, Firefox started supporting DRM via NPAPI since version 47 until version 52, when decide to remove NPAPI support (March 7, 2017).
Prior to this date, Firefox has been steadily improving their platform adding features to become native Web APIs, mirroring actions of other browsers.
From then, as you can see here: https://wiki.mozilla.org/QA/Widevine_CDM, Linux was and still is NOT be part of the test scope, so it will be an slow progression.

So this is not an issue of Spotify, probably the message page could be more specific, but there is nothing else to do (in some flavors of Linux).

If you still want to keep troubleshooting this for your specific system, you could turning on logging like a firefox developer has described here at https://support.mozilla.org/en-US/questions/1135638?page=2#answer-913708  for a moment and share the results with us.

Best!

Highlighted

Re: Unfortunately DRM is not enabled

Newbie

.

Highlighted

Re: Unfortunately DRM is not enabled

Newbie

It seems that Google frakked up the Chromium (and Chrome) regarding this DRM debacle.

In my case I can use the web player in Firefox (with enabled DRM in the settings):

- Arch Linux

- FF 54.0.1 (64 bit) at the moment

 

So my Chromium 60.0.3112.78 (Developer Build) (64-bit) is numb for now.

 

You can read some confusing stuff here why things are ruined.

 

BTW why people are using this piece of **bleep** Chrome? Use a proper browser like Firefox, or Chromium or even Opera! Everything is better that this branded **bleep**.

Highlighted

Re: Unfortunately DRM is not enabled

Regular

Hi,

Some minor improvement for Ubuntu and FF 54.x, installing ffmpeg package:

 

sudo apt-get install ffmpeg

 

This fix the awful error message:

The video on this page can’t be played. Your system may not have the required video codecs for: audio/mp4, video/mp4 -> browser.xul

 

Highlighted

Re: Unfortunately DRM is not enabled

user-removed
Not applicable

How to fix this? 
I realy need use my spotify, i pay for premium. 

Get the old desing back or screw you!

SUGGESTED POSTS