Announcements
Current information of our Google Nest Mini Offer can be found here.

Web Player won't work on Firefox for Linux

Reply
Highlighted

Web Player won't work on Firefox for Linux

Music Fan

I'm back again with another frustrating issue. Spotify is really spotty, and the lack of official support is starting to wear thin.

 

I am trying to listen to music on my CentOS 7 64 bit machine. When I try on Firefox 57.0.1 it exhibits the same behavior as I've noticed, I click on play, the album shows up in the bottom bar, and ... nothing happens. Time doesn't progress, nothing plays.

When I open up Chrome, in the same OS, it plays fine. But I do most of my work in Firefox and way to stay in Firefox.

Before you suggest it, here's what I've tried. Please don't suggest the below as I've already verified it.
* I've enabled DRM playback
* I've updated flash (not that it should matter)
* I've enabled autoplay
* I've clicked on the connected devices on bottom and tried selecting This Web Browser
* I've tried logging out and logging in everywhere
* I've tried logging in via a desktop client somewhere else (I don't have root on this machine, hence the desire to use the web player)
* I've tried clearing the cache and cookies

SUGGESTED POSTS