Announcements

Web Site play button problem

Reply

Web Site play button problem

Newbie

 

Plan

Free/Premium

 

Device

Web Platform

Operating System

All

 

My Question or Issue

 

hi, I am developing a web site. And I want to add a play button iframe in my website.

When I try to load the iframe the consol throws this: 

Refused to display ["spotify_share_url"] in a frame because an ancestor violates the following Content Security Policy directive: "frame-ancestors 'none'".

 

What can I do to fix that?

 

Thanks

 

3 Replies

Re: Web Site play button problem

Rock Star 17
Rock Star 17

Hey @adri21112! Welcome to the Spotify Community. ^^

 

That's odd.

Are you still experiencing this issue?

 

Peace

NicoRock Star 17
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Re: Web Site play button problem

Casual Listener

Has anyone found what could be causing this?
I'm experiencing the same issue. If I'm not logged I see the frame no problem and I'm asked to login. Once I login I get this message on console.

Refused to display [playlist_link] in a frame because an ancestor violates the following Content Security Policy directive: "frame-ancestors 'none'".

This happens on Google Chrome: Versión **bleep**.0 . 3497.100 (Build oficial) (64 bits)

Any help would be appreciated.

 

PS: That's Chrome sixtynine, the filter doesn't like that number...

Re: Web Site play button problem

Spotify Legend

Hey @adri21112 and @A2020,

 

Head over to this page where you can get help from Spotify for Developers. There you'll find all the answers 🙂

 

Good luck! Let us know if you have further questions.

 

Have a nice day.

 

SUGGESTED POSTS