"Spotify no longer supports this version of Firefox. "

Reply

"Spotify no longer supports this version of Firefox. "

butwevegotheart
Gig Goer

About 30 minutes ago, I started getting this error message on the Web Player: "Spotify no longer supports this version of Firefox. Please update your browser for uninterrupted listening." I'm already using the newest version of Firefox Quantum, 68.0.1, so this message doesn't make any sense. And yes, I've double-checked that I'm up-to-date. I'm including a screenshot of the error below.

  • WP
Spotify2.png
13 Replies

Xugpa
Visitor

Hello,

 

I did the following - logged out of any Spotify Web Player opened, played one/two songs on Spotify on my mobile, then tried it again on Firefox and it worked.

 

I've tried the solution described in this thread:

"https://community.spotify.com/t5/Other-Partners-Web-Player-etc/Web-Player-not-playing-music-Firefox...

 

As the original poster wrote below:

 

"It's as if the browser/web player is, for lack of a better term, "stuck". With the web player open, I played music with the Spotify app on my phone, clicked Devices Available on the bottom of the app, and then switched it to Spotify Web Player. The browser/web player started playing like normal again, as if it got "unstuck". If it's indeed the same problem, worst case you might need to fiddle with different devices playing back to the web player (and vice versa, also might need to close and reopen web player) to get it working again."
Give it a try !

andymusiclover
Casual Listener
Thanks for the suggestion. But does not work for me. Your method is good for when browser won't play due to the devices being confused, but it doesn’t seem to fix this issue. Anyone?

KnooL
Casual Listener

This morning I was able to play music through the browser. Changed throughout the day giving me the error you described on Firefox 68, Windows.

KnooL
Casual Listener

I solved the issue by removing 0.0.0.0 redirector.gvt1.com from my hosts file. This entry blocks Firefox from updating the Widevine Content Decryption Module provided by Google.

 

If this doesn't immediately fix the problem for you, untick 'Play DRM-controlled content' under 'General'. This will force the uninstall of the DRM decryption module. Tick it again and visit Spotify to download the DRM module once again.

yafmiko
Visitor

Hi KnooL, the disable-and-reenable-drm worked for me, thanks!

(disable drm checkbox, close ffox, start ffox, enable drm checkkbox, open spotify web player, get notification about installation of audio codecs, works.)

joergumbi
Newbie

Unvortunately doesn't work for me.

hahcho
Newbie

Thank you! I was starting to think spotify messed up seriously their web client.

andymusiclover
Casual Listener

Had same issue, so tried on latest Chrome, then latest Safari -- all give the same popup! Is this a ruse to force listeners to download the desktop app?....

mattlambertson
Visitor

Having the same problem. I clearly have the latest version, as shown:

 

spotify.jpg

adsadsdas
Visitor

Having the same problem in here.

I've updated from Fedora 28 to Fedora 30 in order to solve the problem but without results.

cant_play.png

tpk1
Visitor

I had the same problem and the Spotify support on twitter suggested to clear cookie/cache and/or log-in using an incognito window. It did the trick 🙂

butwevegotheart
Gig Goer

They also told me to try the incognito window trick, and it did work for me, but I still can't listen without the pop-up message in a regular window, so there's still some kind of bug that needs fixed.

carminepharaoh
Newbie

didn't work for me

SUGGESTED POSTS