Alexa Echo Dot 1st Gen Spotify Skill won't work

Solved!
Reply

Alexa Echo Dot 1st Gen Spotify Skill won't work

witte84
Casual Listener

I have spotify linked to an echo dot and everything worked fine the past years. Since a couple of weeks spotify stopped working.

 

When I say "Alexa play spotify" it returns with "to play spotify enable the skill and link your account".   

 

What I tried so far:

1) disable and re-enable the skill in alexa app

2) logged in on spotify and deleted "alexa" from the apps, then disabled and re-enabled the skill in alexa app + account linking 

3) deleted "alexa" app in spotify account, disabled spotify skill in alexa app, uninstallled alexa app, rebooted phone, installed alexa app, factory reset echo dot, configured echo dot again and enabled spotify skill 

4) same as 3 but on other smartphone 

5) same as 3 but with spotify account of my wife instead of mine   

 

 

Any advise?

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

witte84
Casual Listener

Hi @CarlosE,

 

Amazon support did fix this! Thanks for the tip!

 

View solution in original post

7 Replies

MafeG
Moderator
Moderator

Hi @witte84,

 

Welcome to the Community and thank you for posting. 

 

Great troubleshooting so far! To continue, please try the following:

  1. Unlink your Spotify and Alexa accounts. Find how here.
  2. Turn your Echo speaker off.
  3. Restart your router by unplugging it from power for at least 15 seconds.
  4. Log out from your Spotify account, restart your phone, and log back in.
  5. Turn on your Echo speaker and link your accounts again.

Let us know how this goes!

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“When the power of love overcomes the love of power, the world will know peace. - Jimi Hendrix

witte84
Casual Listener

Hi @MafeG,

 

Sorry for the late response.

I was able to test this today. I followed your instructions step-by-step but unfortunately still the same result.

 

Any advise on  what to do next?

 

Kind regards

MafeG
Moderator
Moderator

Hi there @witte84,

 

Thank you for your reply 🙂 

 

There are other things we can try here. Please log into your Spotify account, then access this link and revoke access to Alexa

 

Then open the Alexa app on your phone and tap More. Then go to Settings > Music & Podcasts, select Spotify and make sure the option Enable to Use is selected. 

 

Hope this helps, we'll be on the lookout.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“When the power of love overcomes the love of power, the world will know peace. - Jimi Hendrix

witte84
Casual Listener

Hi @MafeG,

 

This is pretty much the same thing as I die before but in another way. But to be sure I tried this, unfortunately with the same result.

 

Regards,

Kris

CarlosE
Moderator
Moderator

Hi again @witte84,

 

Thanks for trying and keeping us posted.

 

In this case, we suggest reaching out to Amazon support for further info on what might be causing this.

 

Hope it gets sorted out. If you have any questions or need anything else, the Community is here for you.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
Solution!

witte84
Casual Listener

Hi @CarlosE,

 

Amazon support did fix this! Thanks for the tip!

 

View solution in original post

CarlosE
Moderator
Moderator

Hey @witte84,

 

We're glad to know it was sorted out 🙂

 

If you need a hand with anything else, the Community is always here for you.

 

Take care!

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
SUGGESTED POSTS