Announcements

Alexa smart speaker doesn't play Spotify premium.

Alexa smart speaker doesn't play Spotify premium.

Nkhankan
1) In the Alexa settings, Spotify is the default player and is linked. Alexa is logged on.
2) The smart speaker (Ultimate Ears Megaboom) is listed as the current device in the Spotify settings;
3) the speaker was hard reset and everything reentered.

The speaker's Alexa assistant works fine with other tasks, but when asked to play music it says it is going to do so from Spotify, then... silence. None of the other devices with the Spotify account are operating when making requests of the speaker. FYI, this was not a problem about 6-9 months ago; the speaker responded to music requests and pulled the music from Spotify just fine.
Reply
31 Replies

Alex

Hey there @Nkhankan,

 

Thanks for the post.

 

Can you try playing music from another device like your phone/ PC and the switch playback over to the smart speaker using Spotify Connect? Does that work, or you still can't hear anything from the speaker.

 

Keep us posted on how you get on.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Nkhankan

Thanks for trying, Alex. The speaker plays music from Spotify running on my iPhone when selecting the speaker through Spotify Connect or as the bluetooth device for sound.  When I power down the phone mid tune, the song plays through to the end. No other song plays and making a music request of the speaker's Alexa assistant gets an acknowledgement of the song and artist name with the identifier "from Spotify" but no music plays. Non music requests of the Alexa assistant give appropriate responses, as before. 

 

There is a disconnect between the Alexa/Ultimate Ears smart speaker recognizing a music request and actually accessing that music from Spotify. Any other suggestions I can try?

Kiril

Hey there @Nkhankan,

Thanks for keeping us in the loop here.

As an additional suggestion we can recommend you to to try and restart your network's router device (give it a cooldown of like 30 secs) and check once again if all of your devices have their firmware up to date (have no pending updates). If in doubt you can also run a clean reinstall of the app, which is more thorough than the normal one and ensures that no cached data will cause interference with the new installation of your app. 

 

It's also important that you're using the correct voice commands for Alexa to be able to fulfill your requests. Here is some more info on the voice commands and how they should be used properly for best results.

Hope you find this useful. Keep us posted if you have any questions.

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Nkhankan

Kiril, the recommendations you thoughtfully outline are for the phone however the problem is with the smart speaker, which should not require any other device to access Spotify through its Alexa assistant. I tried restarting the router and performed a factory reset of the speaker. Still a disconnect between Alexa acknowledging a request to play music from Spotify and actually accessing the music through my account even though the login is correct. No error code is ever given that Spotify could not be accessed, just silence where there ought to be music. Given the complexity of the situation, Ultimate Ears blames Alexa and Spotify, Amazon blames Spotify and Ultimate Ears. At least this forum through Spotify has done more to try to fix the problem than the other two.

Dian

Hey @Nkhankan,

 

Thanks for the updates on the troubleshooting steps you've tried.

 

Could you check the region settings on your Amazon and Spotify accounts? They should be matching. If that is not the case, update the region on the Amazon account accordingly.

 

Have you also tried a ground up relinking of your Amazon and Spotify accounts?

 

Keep us posted,

 

Cheers!

 

 

DianModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Nkhankan

@Dian

The region settings are correct and I did a factory reset on the UE smart speaker which required me to re identify Spotify as my Alexa default for music instead of Amazon. Alexa on the speaker does indeed state that it is directing the request for music to Spotify but no music plays. Either Alexa is not really communicating with Spotify or vice versa. Still stuck with a not so smart speaker that only plays music from an external device. 

Dian

Hey @Nkhankan,

 

Thanks for the replies and the troubleshooting steps you've tried.

 

It would be important for us to know, if nothing starts playing via Spotify on the speaker when using a voice command. Have you tried different playlist (created and not created by you) names or specific songs/artists?

 

It is also worth trying to link another account with the speaker, so we can be sure, that this is not an account related issue.

 

Keep us posted,

 

Cheers!

DianModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Justagirl07

The same thing is happening to a lot of us. There and MANY comments in the Alexa app reviews of Spotify complaining about this for months. 

Dian

Hey @Justagirl07,

 

Thank you for posting in the Community.

 

In order for us to find the best possible solution, could you share more information on your experience like the troubleshooting steps you've already tried, but didn't work? This way we can avoid repeating the same steps and can provide further advice.

 

We'd also need the brand/model and operating system of the affected devices.

 

Let us know how it went,

 

Cheers!

DianModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

bpedric1

I am having the same issues with my MEGABOOM.  Spotify premium is set as my default all music voice commands result in the same outcome. UE responds says it's playing "blank" from Spotify than just silence.  If I ask it to play another service it plays the music with no issues.  This has been an issue for about 2 or 3 months now.  I think it might be time to take my money to another music service that supports the platforms it claims to support. 

bpedric1

Correction: I am having the same issues with my MEGABLAST.  Spotify premium is set as my default all music voice commands result in the same outcome. UE responds says it's playing "blank" from Spotify than just silence.  If I ask it to play another service it plays the music with no issues.  This has been an issue for about 2 or 3 months now.  I think it might be time to take my money to another music service that supports the platforms it claims to support. 

Eni

Hey there @bpedric1

 

Thanks for reaching out about this. 

 

Could you let us know which troubleshooting steps you've already tried? That way we can avoid any repeating steps. 

 

Also, we'd like to know if this started happening after a specific event such as an update either of Spotify or the firmware of your speaker. 

 

Keep us posted.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Justagirl07
I have tried to factory reset, checking for updates, uninstalling the app
on both my phone and Alexa device as well as logging out and logging in.
This occurred back in December after an update on my Alexa but then was
fixed for almost a week back in February without an update near that time.
Then it went back to not working since. I am able to connect my phone to
the Alexa through Bluetooth and play it that way but not by asking Alexa to
play the music. Spotify does not recognize my device when I attempt to
reconnect it either.

AndresM

Hey @Justagirl07,

 

Thanks for your reply. 

 

Could you send us the make/model, OS version and exact Spotify version installed on your device?

 

Changing tunes, we suggest checking for firmware updates on your Alexa device and verify if the issue persists even when linking your speaker with another mobile phone. 

 

Keep us in the loop.

AndresMModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Music touches us emotionally, where words alone can't." -Henry Thoreau

Nkhankan

@Dion, the region settings are correct and the ground up relinking of my Amazon and Spotify accounts was done when I did a firmware reset. Still didn't fix the problem.

Nkhankan
@Alex, starting something on Spotify via my iPhone then connecting to the smart speaker via bluetooth and designating it as the sound output works fine; I can hear whatever song I request from Spotify on my phone. The problem is that the speaker is supposed to work independently of the phone by accessing Spotify through the Alexa assistant. Alexa acknowledges the request, states that it is going to pull the music from Spotify, then silence. I thought to see if perhaps there was a way to confirm that the request to Spotify was actually made by having the Ultimate Ears smart speaker transfer the requested song to my phone, but I cannot figure out if that is possible.

Sexmonster

Same Problem here for. 6 Month now. Tried everythink. Just tell the engineers ti fix it!

Niggel2

I'm having the Same problem here for a few months now and so is my brother . As others have said maybe time to switch to a different music player as no one seems to have an answer 

deva11

Same problem here. I’m using Libratone Zipp Mini 2 with Spotify and Alexa. Everything used to work great until ~6 months ago. Its the same issue people above have stated: I make a request, Alexa acknowledges it and says its gonna play what I requested, and then just silence. Manually using Spotify Connect from my phone/PC works fine, the problem is Alexa and Spotify are not communicating properly for some reason. I’ve already checked all settings in the Libratone, Alexa and Spotify app, as well as my network settings, so the issue is definitely not on my end.

Suggested posts

Env: prod