Reply

Amazon Echo Group does not react

chaltenhoff
Music Fan

I have a pair of two Echo 4 named 'bedroom'. I can see it in Spotify but for some days now it does not react. If I tap on it nothing happens. I have to disconnect from the device and by saying 'Alexa, Spotify Connect' assingning it anew. All other groups with Chromecast or Sonos devices work fine. 

New pairing and deplugging power did not work 😞 

12 Replies

Alex
Moderator
Moderator

Hey @chaltenhoff,

 

Thanks for reaching out about this in the Community!

 

Can you clarify if you're playing music from the smart speakers directly via voice command or using Spotify Connect via your phone/laptop? If your using Connect from another device let us know if it works normally when you stream music from another device.

 

It's also a good move to check whether all your speakers are running the latest firmware and if they have any updates pending.

 

We'll be on the lookout for your reply.

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

chaltenhoff
Music Fan

Hi Alex, I tested from the Spotify-client on my notebook and with my iPad now. And in deed I can choose the group from there. By the way, as long as I play on one device the group is not visible on all others. 

The only device on which the group does not react in most cases is my mobile. It's a Xiaome Mi A2 with Android 10 and newest Spotify update. 

Eni
Moderator
Moderator

Hi @chaltenhoff

 

Thanks for getting back in touch. 

 

In this case, it's well worth running a clean reinstall to get rid of any cached files that might be causing trouble. This one is more thorough than the usual one.

 

If this doesn't make the difference, we suggest that you unlink and then link your Spotify account again to Alexa. You can check this article to know how to do so. 

 

Let us know how it goes!

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

chaltenhoff
Music Fan

Did the clean reinstall. And linked Spotify anew.  Did not solve the problem. Maybe it has to do with the bug of the Echo 4 which lets it not work propperly as a group (see my other post regarding this). Because it works fine when I disconnect the pair and connect them solely. But then it shouldn't work with iPad or windows app either.

 

Mihail
Spotify Legend

Hey @chaltenhoff,

 

Thanks for getting back to us.

 

The troubleshooting you've done so far indicates that something is interfering with the app's connectivity on your smartphone. Could you please check that all there are no updates for your system? 

 

It's also a good idea to make sure that the app has all necessary permissions and is excluded from any storage and optimization services. You can follow these steps:

 

1. Mobile Settings> Apps> Spotify> Permissions. Allow everything you see there.

2. Mobile settings> Apps> Spotify> Battery> Optimize battery usage> select top All (not optimized for apps)> Spotify> disable.

3. Last step - restart the phone.

 

Note that the menu order may differ on different devices.

 

Hope you find this useful. Keep us posted how you get on.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

chaltenhoff
Music Fan

Tested all the above. Unfortunately no success. So I did a factory reset. But still no change. Tested also with another Android phone. No problem there. So I would say it must have to do something with the Android One system software. What else could it be?...

Novy
Moderator
Moderator

Hi again @chaltenhoff,

 

Thanks for getting back to us. 

 

Would you mind letting us know the make, model, exact OS version and Spotify version of the Android device in which you had no issues? 

 

We'd also recommend going to Your Library > Settings > Devices. Under Devices, make sure ‘Show local devices only’ is toggled OFF.

 

Let us know how it goes.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

chaltenhoff
Music Fan

The device on wich it functioned is a Xiaomi Redmi 7A with Android 10 that had no Spotify Update for some weeks. Unfortunately i updated it today and now it has the same problems as my Mi A2.  Both have Spotify Version 8.5.94.839 now. 

 

Before updating the Redmi 7A I recognized that there was one setting more than in Spotify Version 8.5.94.839 under 'Devices'. It was something like 'Allow Spotify Connect to work in background'  (I try to translate from German).

That setting is now not available anymore on both phones. 

 

Most of the time I can not connect to Amazon Echo Groups and to Sonos Groups. 

Sometimes it works but thats like 1 in a 100.

 

 

Novy
Moderator
Moderator

Hey @chaltenhoff

 

Thanks for your reply!

 

Just to confirm, have you made sure that your speakers are running the latest firmware version available?

 

If possible, could you try restarting your router to see if you notice anything new?

 

We'll keep an eye out for your reply. 

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

chaltenhoff
Music Fan

I reset the speakers and checked that they have the latest software. And I restarted the router. But for me it seems to be an issue with the Android app as it works on IPad and from my notebook.

CarlosE
Moderator
Moderator

Hi again @chaltenhoff,

 

Thanks for keeping in touch.

 

If possible, could you give it a try on a different Android 10 device that isn't a Xiaomi? This will be helpful to narrow down the possible cause of the issue.

 

Keep us posted. We'll be on the lookout.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

chaltenhoff
Music Fan

Hi. 

I testet with a Samsung J5 today. Same problem there. On all four Android devices I tested single Echo devices play emediately. Echo- and Sonos-Groups do not react. Sometimes they play after toggling several times between them, other devices and the mobile phone itself. 

On IOS and with windows app there is no problem.

So I think the issue is clear now. Its the Android app that does not function with grouped devices. 

SUGGESTED POSTS