Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Amazon Echo dot unable to play spotify.

Solved!

Amazon Echo dot unable to play spotify.

Djt2019

 

Plan

Premium

Country

 Canada

Device

Samsung galaxy A5

Operating System

 Android version 8.0.0

My Question or Issue

 I have a spotify account and got an amazon echo dot for christmas and my account in the alexa app says it is linked and is the main music app but when i ask alexa to play spotify she says: "your spotify account doesnt support streaming on this device" and when I try the link to devices in the app it doesnt work either.

Reply

Accepted Solutions
Marked as solution

Jemi

Hey @Djt2019, help's here.

 

In order to use voice commands to control your music with Amazon Alexa, your Spotify accounts needs to be on Premium. It's possible that you have another account which is on Free that you've logged into.

 

We suggest that you log out from your app, and relink your account with Alexa, but this time make sure you're entering the correct details for your Premium account (double-check that you can use other Premium features when logging in such as downloading your music or ad-free listening): 

 

  • ‘Settings’ in the Alexa app gives the option to unlink a Spotify account.
  • Verify that you want to unlink your account.
  • Relink your accounts with these steps.

 

If you're having trouble, you can see if you have other accounts with these steps.

 

Hope that helps! 

View solution in original post

4 Replies
Marked as solution

Jemi

Hey @Djt2019, help's here.

 

In order to use voice commands to control your music with Amazon Alexa, your Spotify accounts needs to be on Premium. It's possible that you have another account which is on Free that you've logged into.

 

We suggest that you log out from your app, and relink your account with Alexa, but this time make sure you're entering the correct details for your Premium account (double-check that you can use other Premium features when logging in such as downloading your music or ad-free listening): 

 

  • ‘Settings’ in the Alexa app gives the option to unlink a Spotify account.
  • Verify that you want to unlink your account.
  • Relink your accounts with these steps.

 

If you're having trouble, you can see if you have other accounts with these steps.

 

Hope that helps! 

Djt2019

Hey Jemi, thanks for the help!

 

I logged out and back in then made sure I was on the local wifi, asked alexa to "spotify connect" and then it appeared in my available devices finally. It is currently working.

Djt2019

Ok new update: I have it playing music and connected to my phone (I believe via the wifi link) but when I ask it to play a song eg: 11 blocks by wrabel. The echo dot says the same "your spotify account doesnt support streaming on this device" 🤔 and then continues playing music from the app. It shows im connected to "Daryn's echo dot" in the available devices but wont let me select/change song unless I use the app.

Peter

Hey @Djt2019.

 

Thanks for getting back to us, and sorry for the wait!

Just to confirm, is the issue that you aren't able to give the Echo Dot any commands, or is there more to it? 

If it's the former, could you try unlinking/relinking your Echo Dot to Spotify again? If that doesn't work, then could you try doing it via this link? Make sure to do this in different browsers and/or in an incognito window.

 

Let us know how it goes 🙂 We'll be here if you need any further help.

Suggested posts