Can't control Echo Plus volume through Spotify

Reply

Can't control Echo Plus volume through Spotify

Skellingtor
Community Legend

Plan: Premium

Country: Brazil

 

Device: Amazon Echo Plus (2nd Generation), Samsung Galaxy S7, MacBook Pro early 2013

Operating System: Amazon Alexa, Android 8.0, macOS Mojave 10.14.5

 

My Question or Issue

For the past week or so I've been unable to control volume levels on my Spotify apps, desktop and mobile. I've tried all sorts of things, from reset, factory reset, changing language, downgrading the Alexa app, uninstalling Spotify, but nothing has worked. It's a mild inconvenience, but I'd really like some help with this.

21 Replies

Skellingtor
Community Legend

I know bumping posts is frowned upon but I have no choice since I've received zero response from anyone around here. This problem is still ongoing after many updates to my mobile and desktop apps.

Skellingtor
Community Legend

If anyone knows what's up I'd still like to know

tempguest123
Visitor

If you connect your echo device to bluetooth, you will be able to control the volume from your spotify app. For some reason the "in-app" volume control doesnt work anymore. 

matvcd
Visitor
eu também estou com esse problema, do nada parou de funcionar af

AdmiredDragon
Music Fan
Hello, it's me the OP. I changed Spotify accounts and therefore also changed my username. Anyway...

The issue seems to have fixed itself. I started using my Echo again recently and I've been able to change the volume from the desktop and mobile apps with no problem. God knows what the issue really was, but I guess he won't tell us.

You may mark this as solved.

rahulrmak
Visitor

Had this problem for the longest time and it was very irritating. 

Seem to have fixed it - 

  • Forget the device in Spotify 
  • Select the device again in the list
  • Play a song
  • Open alexa app on the phone 
  • Increase/decrease volume once from the music controls
  • Head back to Spotify
  • Now volume up/down works

adiamond
Casual Listener

Disable the Spotify skill in the Amazon Alexa app (phone or desktop) then enable it again.  Should fix the problem.

paolomch
Visitor

This ia the solution. Many thanks.

adiamond
Casual Listener

My previous response seems to only provides a temporary solution. 

 

Although a little cumbersome, here is the solution that currently works for me:

 

After selecting a source from within Spotify (e.g. kitchen echo), change the source back to your phone, then change the source back to the desired location (e.g. kitchen echo). 

 

 

Kweatherz
Visitor
Thankyou! Was looking for a solution and this worked straight away 🙂🙂👌

tarek_ghouri
Casual Listener

make sure that your phone is on the same Wi-Fi network!  Many routers have mixed 2.4ghz and 5ghz. If your iPhone (for example) is on the 5ghz network you can open and play Spotify no problem but the volume doesn’t work. Stupid huh!  If you switch your phone to the 2.4ghz (the same one the Alexa should be using) then the volume works just fine.  Took me several weeks to figure this annoying item out.  

jagger21212121
Casual Listener

This worked for me. Actually I went to Spotify settings and then devices and told it to forget all my echos and then just Alexa to, “play music” from Spotify on each device. As each one was added back I was then able to control devices again. Also, I never lost the ability to control each devices volume in the Alexa app by clicking on “Devices” then “Echo & Alexa” at tbe top then picking a group with tbe device in the group I had made and then turning the volume down there.” But that is a very long way to go to turn a device down and using my phone’s volume control is MUCH easier so thank you to all here who posted. You got me back on the right path and I just created an account to say, “Thanks. You guys rock.” Stay safe! 

pumany
Casual Listener

So here it is one year later and I’m reading this post because I’m having the issue.  Can someone please reply if they are having as much frustration as I am with getting decent support for this app?  I’m very close to trying a different service, which is a shame!!

rKellz
Casual Listener

This is a temporary fix. You need to do this again intermittently. 

jagger21212121
Casual Listener

Um. Not true for me. At least since my last post in May. Time will tell. I will come back and tell you if I am wrong. I have 4 echos and 3 echo shows and I can control volume on all of them after the fix. 

coldbobt
Music Fan

Thanks dud e for the source swap ideas, this was doing my head in on my Echo Plus/Sub system, these Spotify belters never seem to help out on here...

jagger21212121
Casual Listener

Cool. 

RsIV
Visitor

Thank you for this solution.

Stevespot1
Visitor

New to all this, sorry if I’m breaking any rules, not sure what bumping means. Or if someone has already answered this.

Found out by accident - couldn’t adjust volume within Spotify app connected to an echo device. In the area where you choose to play through your phone or echo devices - swap from phone to device a couple of times seems to kick in the volume control. Have to do this every time, obviously a Spotify bug. Bluetooth is not a good option, when taking a call I don’t want to broadcast it over the house.

SUGGESTED POSTS