Help Wizard

Step 1


Can't find Spotify app on PS5

Can't find Spotify app on PS5







PlayStation 5

Operating System



My Question or Issue

I can't find the Spotify app on PS5. It is not listed under "All Apps" or when searching the store.


According to Sony's official webpage, Spotify IS available in Israel on PlayStation:


I tried PlayStation support (the Israeli support center) but the rep, although a very nice guy, was as bewildered as I was and none of his suggestions helped.


Please help.

2 Replies

Hey @whateveruknow,


Thanks for reaching out to the Community with this one.


You're right that Spotify on PlayStation should be available in Israel, but please keep in mind that the availability on the Store is handled by Sony, not by Spotify. We recommend that you double check your country settings and restart your device, if you haven't already. This is a simple, but often overlooked step.


It's a good idea to also connect your PlayStation to a different network and see if the Spotify app is available then. A mobile hotspot can be a convenient way to test this. If it works with another connection, it's best to contact the service provider of the original network for more information. 


There is also the option to perform a factory reset, as this will clear the device of any possible damaged files.


If these steps don't fix things, you should turn to Sony's Customer Service.  


Hope this helps. Keep us posted on how it goes.  

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi Mihail


Thank you for your response. I tried your suggestions to restart the device and check country settings on the device, to no avail.


I did a little extra digging on my side, to discover the following:

On a whim I created a new PSN user, this time selecting United Kingdom as the country of residence. And wouldn't you know, Spotify became available for download. I downloaded the app and even linked by account. Everything worked.


This is obviously less than ideal, since all my data is on my original account.

But I understand Sony is likely to blame here.


Hopefully this helps others in a similar situation.

Suggested posts