Connect - Autoplay DISABLED, but still ACTIVE

Reply

Connect - Autoplay DISABLED, but still ACTIVE

JalapenoMunich
Roadie

Plan

Premium

Country

Germany

Device

Samsung Galaxy A51, Windows 10 notebook

Operating System

Android 11, Windows 10

My Question or Issue

I'm listening on several Sonos speakers via Connect. Recently, Spotify has started playing other music once the album I listen to has finished - i.e. it's using the Autoplay feature. Problem is: Autoplay is DISABLED on all devices, but it's still being used. How do I fix this? (I've already reinstalled Spotify on all devices.)

 

291 Replies

hbunjes
Regular

Oh, i haven’t found this thread before. Thank you for linking it here. 

i cannot believe that this is intended behavior…

antonius_sdf
Regular

Just chiming in, I have the same issue on my phone and desktop (iOS, macOS, everything updated). I reached out to Spotify on Twitter, they gave conflicting answers (this is expected behavior and has never been different AND it's been passed on to the right team for a fix). I hope it gets fixed soon. 

 

I tried making a single-album playlist and play that to have something to fall asleep to (as I did forever), but those get autofilled too. Release Radar doesn't, funnily...

JalapenoMunich
Roadie

By now, there's at least ten different threads on this issue here in the forums. And yes, they contain conflicting answers by the Spotify team, including the claim it's intended behavior.

 

If it is, it's a horrendous design decision that needs to be reversed. But I'm convinced it's a bug that was introduced via a new update around the time I started this thread.

 

Please fix it, Spotify, it's annoying as **bleep** and makes me want to cancel my subscription.

amynalan93
Regular

@antonius_sdf: I have the same habit. Try this: with the playlist queued up and playing or paused, being up the contextual menu and select"sleep timer." This, fortunately, is still working.

Kiril
Moderator
Moderator

 Hi there @ajhawar32 ,

 

Thanks for your reply and the attached video.

We've taken a look, but from the video it's not really clear, where do you click and what exactly happens on your end. Can you confirm if you are activating/disabling the Connect feature in the video above, as this isn't visible and it's essential for us to know. 

 

Could you also mention your current version of the Spotify app? 

Keep us posted, we'll be on the lookout for your reply.

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

ajhawar32
Regular
Sorry - autoplay is toggled off in that video. What I am changing is going
from Spotify Connect (during which it adds an autoplay to my queue) to
device speakers (during which the autoplay disappears).

mazzacat49
Regular

Hi @Kiril ,
Please find attachedscreenshots with accompanying explanation. 
I tried a video but file size too big.
Cheers

MafeG
Moderator
Moderator

Hi @JalapenoMunich,

 

Thank you for your reply.

 

Certainly we've received other reports about the Autoplay feature, however the one you shared happens specifically when the device is using the Connect feature and not when using the device's speakers/headphones. Is this your case, or does this happen differently? 

 

There are also other reports about Autoplay not turning off in the Web Player.

 

As @Mihail suggested, please let us know if your case fits one of those or if the behavior is different. This will help us narrow this down and give you better assistance. 

 

Keep us posted.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

MafeG
Moderator
Moderator

Hi folks, 

 

We've merged all threads relevant to this issue. As mentioned, we've already reported it with the right folks who are looking into it backstage.

 

For now, please give a try to the troubleshooting steps shared throughout this thread and, if the issue persists, share with us the following info: 

  • Your devices make, model and OS version.
  • The Spotify version you're running.
  • The specs of the device you're streaming to. 

We'll be on the lookout.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

apvanzanten
Regular

MafeG, just to be clear: not everybody suffering this issue is streaming to another device. Just using the web player to play any album directly will do it (as far as I can tell on any browser on any desktop platform). 

Mihail
Moderator
Moderator

Hello everyone,

 

We've noticed multiple threads on the topic of Autoplay concerning connected devices and have done our best to merge them all here. Our goal is to try and keep the communication centralized and clear up any confusion on the matter.

 

First up - we can confirm that as of recently, the Autoplay setting is turned on automatically and by default for any connected device. This means that whenever you play music from Spotify on a device different than natively on your phone or pc/mac (installable apps, not our Web Player) Autoplay will be enabled and tracks will be added to continue playback. This will happen regardless of the current active Autoplay setting. This setting affects only the playback directly on your phone or pc/mac (apps) and does not work universally.

 

As of now there's no way to choose if you want to have Autoplay enabled on a connected device. We assume most of you posting here would like an option for this. As such, it will be really helpful if you go and cast your vote for this idea. This will allow us to better understand how big exactly the demand for something like this is so we can prioritize better. We will follow up on this matter with the right team and try and find out more about this ourselves and will keep you posted.

 

We are also noticing reports about devices that have Autoplay enabled by default, that, at least from what we understand, should not exhibit this behavior. This might explain some of the contradicting info you've stumbled upon. We'll follow up on this as well.

 

Please stay tuned for updates. We understand that this change might cause frustration depending on your music listening habits. It is our humble ask that we keep the conversation civil and friendly. We'll do our best to pass the feedback on, but it can take some time for us to be able to follow up. We promise we will do so as soon as we have anything to share.

 

Thank you!
- The Community Moderator team

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

JalapenoMunich
Roadie

First off: I'd like to apologize that some of my replies yesterday were skirting the borders of what's civil. It's just such an incredibly frustrating issue, but I still should have stayed civil. Sorry about that.

 

On topic:

 

You write: 

 

We assume most of you posting here would like an option for this. As such, it will be really helpful if you go and cast your vote for this idea. This will allow us to better understand how big exactly the demand for something like this is so we can prioritize better.

 

I don't understand why you even changed it. Was there demand from the community to please make it impossible to turn Autoplay off?

 

I also don't understand the need for an idea and the need for as many people as possible supporting that idea. Why don't I understand that? Because a) we're talking about something that was standard until recently, so it's not a new idea it's just "please remove this bug" and because b) the "idea" is offering your users the option to listen to the music they want. That's the most basic feature you could ask for. Why do you need an idea for that? This is really just making it MORE frustrating again.

IcyBloke
Regular

I am in complete disbelief at the statements below.... 

 

"First up - we can confirm that as of recently, the Autoplay setting is turned on automatically and by default for any connected device."

 

"As of now there's no way to choose if you want to have Autoplay enabled on a connected device. "

 

What on earth makes you (Spotify) think that this is an acceptable modification to make without any sort of consultation with your customers?

I am incensed to think that what I believed to be a bug introduced in a recent update is, in fact, a deliberate functionality change, which fundamentally impacts the way I (and I suspect a huge number of others, judging by the number of 'bug' reports raised on these forums) use Spotify.

This change effectively removes functionality with absolutely no benefit for the customer - previously if I wanted to have Spotify choose tracks randomly I could enable autoplay, if I wanted to simply listen to the music I chose, I could - whether I was using a connected device or not, but now I have no choice when listening on anything but a native device... this is ridiculous and unacceptable.

As another commenter has already mentioned, being able to control what is played is a simple, fundamental requirement for any premium music streaming service.

 

 

JalapenoMunich
Roadie

It's like selling a car that doesn't go where you want. Or rather, it does, but you can't get out. It just keeps on going somewhere else, to other places you might want to go. 

 

Honestly, it's mind-blowing. It's removing the one basic thing the entire app is there for: Listening to the music of your choice. 

Godwhacker
Gig Goer

This is absolutely absurd. Why should we have to vote for an "idea" that fixes a bug you've introduced? Just fix it!

 

Regardless of whether I'm connected to smart speakers, or listening on my computer, or my phone, I DO NOT WANT AUTOPLAY. I want to listen to the music I want to listen to, not what your poxy algorithm thinks I want to listen to. 

Sort it out please. If you're not going to, and you keep up this disregard for customers, I'm cancelling my subscription.

KSpace99
Regular

The issue occurs for my following setup:
Amazon Fire HD 8 10th generation, Fire OS 7.3.2.1 (latest)
Spotify 8.6.72.1121 (latest on this device)
Streaming device: Arylic S10
Also occurs on Windows 10, Spotify version 1.1.7.560

Godwhacker
Gig Goer

It's also not particularly helpful that you've now stuck this under "Android"- I don't have an Android device, I'm not experiencing the issue on Android, it feels like you're hiding it so people can't find it.

RorsE
Newbie

Just a shocking design decision. Woken me up every night since it changed. I usually use Spotify via Sonos to play music till I fall asleep to cover up ear ringing, but this is even worse. Would be great if Spotify decided to hire some QA testers.

 

Having to vote for an idea to fix it is the cherry on top of the cake. Can't we just have a generic 'idea' for Spotify to not break absolutely basic features in future? Or do we need to submit an 'idea' in case Spotify decides that playing any playlist should actually randomise all playlists and play them?

ssiimm85
Newbie

I am so, so angry that Spotify doesn't let us turn off autoplay anymore.  Autoplay is infuriating.  If this doesn't get fixed soon, I will be canceling my premium subscription and switching to another service.

antipopmonkey
Music Fan
Reinstalling the apps on iPhone and MacOS did not solve the problem. Connect devices still have Autoplay forcefully enabled. This need to be fixed ASAP.
SUGGESTED POSTS