Connect - Autoplay DISABLED, but still ACTIVE

Connect - Autoplay DISABLED, but still ACTIVE

JalapenoMunich

Plan

Premium

Country

Germany

Device

Samsung Galaxy A51, Windows 10 notebook

Operating System

Android 11, Windows 10

My Question or Issue

I'm listening on several Sonos speakers via Connect. Recently, Spotify has started playing other music once the album I listen to has finished - i.e. it's using the Autoplay feature. Problem is: Autoplay is DISABLED on all devices, but it's still being used. How do I fix this? (I've already reinstalled Spotify on all devices.)

 

Reply
Top Answer
Mihail
Spotify Legend

Hello everyone,

 

We've noticed multiple threads on the topic of Autoplay concerning connected devices and have done our best to merge them all here. Our goal is to try and keep the communication centralized and clear up any confusion on the matter.

 

First up - we can confirm that as of recently, the Autoplay setting is turned on automatically and by default for any connected device. This means that whenever you play music from Spotify on a device different than natively on your phone or pc/mac (installable apps, not our Web Player) Autoplay will be enabled and tracks will be added to continue playback. This will happen regardless of the current active Autoplay setting. This setting affects only the playback directly on your phone or pc/mac (apps) and does not work universally.

 

As of now there's no way to choose if you want to have Autoplay enabled on a connected device. We assume most of you posting here would like an option for this. As such, it will be really helpful if you go and cast your vote for this idea. This will allow us to better understand how big exactly the demand for something like this is so we can prioritize better. We will follow up on this matter with the right team and try and find out more about this ourselves and will keep you posted.

 

We are also noticing reports about devices that have Autoplay enabled by default, that, at least from what we understand, should not exhibit this behavior. This might explain some of the contradicting info you've stumbled upon. We'll follow up on this as well.

 

Please stay tuned for updates. We understand that this change might cause frustration depending on your music listening habits. It is our humble ask that we keep the conversation civil and friendly. We'll do our best to pass the feedback on, but it can take some time for us to be able to follow up. We promise we will do so as soon as we have anything to share.

 

Thank you!
- The Community Moderator team

Top Answer
MattSuda
Spotify Star

As mentioned by @JalapenoMunich 

 

An update has been posted. An option to disable Autoplay on connected devices will soon be coming to the desktop app first and then the mobile app at a later time. The setting works globally so if you turn Autoplay off in the desktop app for connected devices, it will also be off in the mobile app when playing to connected devices.

 

More info here:

 

https://community.spotify.com/t5/Live-Ideas/AutoPlay-Option-to-toggle-Autoplay-on-off-across-all-devices/idc-p/5303176

298 Replies

BaconFat
I'm listening to music on my laptop while working. I have turned Autoplay off, which works fine when listening through the tiny laptop speakers. When I instead connect to my Echo Studio that has much better sound, the Autoplay setting is ignored. I'm still using the same desktop client with the same Autoplay setting.

Which focus group full of drunken chipmunks did you consult to figure out that the Autoplay setting I've explicitly chosen should be ignored just because I'm streaming my sound through a different device?

-dreadpirate-

How in the world does this count as an idea that needs to be voted on? The Autoplay disable setting is flat-out broken.

JalapenoMunich
Yes! This!

-dreadpirate-

To put a finer point on it... the "idea" we're being redirected to (https://community.spotify.com/t5/Live-Ideas/AutoPlay-Option-to-toggle-Autoplay-on-off-across-all-dev...) is about adding a new universal Autoplay setting.

 

But the BUG we're reporting is that the existing Autoplay options isn't working, even on the exact device that we've disabled it on.

 

This isn't a "universal Autoplay setting" idea -- this is a feature that already exists, and is broken.

Bakerfox

Hi,

 

There have been issues with previous versions of Spotify, when connecting to an external device songs will freeze on the screen, but will still play songs.

 

I have recently installed version 8.6.74.1176 thinking that it might fix the issue, unfortunately no solve here, even though a I have cleared cache, uninstall app, then reinstall.

 

Is there an actual fix to this or shall I consider cancel my Spotify subscription and look for something else?

 

 

 

Much appreciated,

Louis

GoodPeace

Spotify Community, your pinned answer has a link to an idea about the webplayer, however this problem is related to native players (on several platforms, but at least on android) when listening (casting) to other devices, such as external speakers. I have the problem with my Sonos speakers as well as a google-home speaker. 

 

Do we need a second idea, or is it related?

GoodPeace
the idea is about the web-player, however this problem is from a native player when listening on external devices.

GoodPeace

Plan: Premium

Country: Denmark

Devices: Pixel 2 phone, Huawei tablet, dell xps13

Operating System: Android 11, Android 10, Linux Mint 20

I have Autoplay disabled on all native apps on all devices. 

If I play a simple 2-track single album on the device, the queue will only have those two tracks. 

If I switch to "spotify connect" to play either on my Sonos or on my google mini speaker, the queue will be filled with other suggested songs, just as if Autoplay was re-enabled. 

This is a newly introduced BUG, as I am 100% certain this has not always been the case. I believe it started about 2-3 weeks ago. 

See attached video using the linux native app on linux mint, where I switch from playing on the laptop to playing on sonos speakers (named: køkken+1).

When I switch back to the laptop, the queue is cleared back to just the two tracks. 

Same thing happens when using google cast to play on a google mini speaker (named Stue mini).

user_y

Like much of the rest of Spotify's UX, and their handling of its shortfalls and defects, categorizing this as "Good suggestion" is lazy and stupid. Not turning off Autoplay on connected devices, when it is turned off in the control app controlling those devices, is a defect. Fix it, Spotify - don't bury it under some feel-good misdirection like "Good suggestion". : |

smbm

Having experienced this whilst playing to my Sonos devices I can say that I do not consider this to be a sensible new default. This is most definitely a regression if the user has no ability to disable it.

There is no possible way I am going to vote on a new "feature" to reverse the effects of this bug. I am more likely to cancel my subscription (Family Plan), sell my Sonos gear and switch to Homepod Minis and Apple Music.

gomezbiased

Free

Argentina

Computer & Web

Windows 10

 

Today I've noticed that after an album, EP, or single ends, random songs of the same genre start playing, I've checked and I have autoplay and repeat disabled.

This is happening both on web and desktop app.

avsfan3196

Thank you for bringing this up here. I'm having the same issue, but it's only happening when I connect to a device (PS4, Fire TV Stick, Google Nest, etc) but not when I listen on my phone. Hopefully someone can help fix this.

Brockish

Well, I just experienced this new little feature and let me be the latest to say: it stinks! And the response in this thread has been incredibly condescending. The idea that it’s on the users to come up with, put forth, and give enough votes to a solution to this for it even be considered is patently absurd. 

sillybones

Removing useful, bug-free, pre-existing controls- like disabling making changes to external device playback settings- is frustrating. But then framing it as a 'new feature' is infuriating. Please revert this and allow users the choice in their playback experience.

phildev

This has been happening to me too for the past 2 hours. I've also checked my settings and autoplay is disabled. I'm playing on a Sonos One.

rossisdead

"This will allow us to better understand how big exactly the demand for something like this is so we can prioritize better.'"

 

Yeah, so can we see "how big exactly the demand" was to force autoplay on all external devices? Seems like absolutely zero user acceptance testing was done with this.

Jaxical

Whose idea was it to remove the disable feature? They should be demoted for ruining a perfectly good service. I’ve been a premium member for over five years and am now looking at other services that won’t force this rubbish on me.

JalapenoMunich

It's a bug that was introduced through a recent update about three weeks ago. Spotify are claiming it's a feature and are saying we have to upvote an "idea" to change it.

 

More here:

 

https://community.spotify.com/t5/Other-Podcasts-Partners-etc/Connect-Autoplay-DISABLED-but-still-ACT...

 

 

JalapenoMunich

Anyone from Spotify still around? What's going on? 

 

Here's a new thread for you to merge into this one. As if that will help anything.

 

https://community.spotify.com/t5/Accounts/Random-songs-playing-after-an-album-ends/m-p/5291446

betamaxdk

Would be very nice to be able to disable autoplay again. There's a reason I disable it on all my devices, and of course I also want this setting to affect playback on connected devices. Can we get an ETA on the bug fix?

Suggested posts