Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Connect - Autoplay DISABLED, but still ACTIVE

Solved!

Connect - Autoplay DISABLED, but still ACTIVE

Plan

Premium

Country

Germany

Device

Samsung Galaxy A51, Windows 10 notebook

Operating System

Android 11, Windows 10

My Question or Issue

I'm listening on several Sonos speakers via Connect. Recently, Spotify has started playing other music once the album I listen to has finished - i.e. it's using the Autoplay feature. Problem is: Autoplay is DISABLED on all devices, but it's still being used. How do I fix this? (I've already reinstalled Spotify on all devices.)

 

Reply
Top Answer
AlejaR
Moderator

Hey folks,

 

Thanks for all your replies.

 

@Primordial_Radiance, we'd like to confirm, is your account on free service? If yes, keep in mind our free experience on mobile is different: music on-demand is a Premium feature, so it's expected for the app to add suggested tracks within the same album/playlist. This is not the same as Autoplay. You can read more about it here. Keep in mind, these recommendations are going to appear, even if you disable Autoplay.
 

If your account is Premium, it'd be really helpful if you sent us a video recording of what's happening. You can attach the video to your next reply in mp4 format, or you can also upload it to YouTube or Google Drive and make it public, so we can visualize it.

 

Keep us in the loop!

Top Answer
MattSuda
Spotify Star

As mentioned by @JalapenoMunich 

 

An update has been posted. An option to disable Autoplay on connected devices will soon be coming to the desktop app first and then the mobile app at a later time. The setting works globally so if you turn Autoplay off in the desktop app for connected devices, it will also be off in the mobile app when playing to connected devices.

 

More info here:

 

https://community.spotify.com/t5/Live-Ideas/AutoPlay-Option-to-toggle-Autoplay-on-off-across-all-devices/idc-p/5303176


Accepted Solutions
Marked as solution

UPDATE 2-7-2023:

 

The "Autoplay" setting was recently updated. The single "Autoplay" setting in the desktop and mobile apps will now enable or disable Autoplay across all devices on your account. This change makes it easier to manage instead of there being 2 different settings.

 

You only need to change the Autoplay setting in one of the apps, either desktop or mobile, and it will apply to your account on all devices including the Web Player and Spotify Connect devices.

 

You can read the support article for more information about the Autoplay feature.

 

At the end of 2021 a second setting was added to turn on/off Autoplay on the Web Player and Connect devices, but now it's just one single setting.

MattSudaSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

View solution in original post

328 Replies

Edit: I just noticed that I can't remove the Autoplay songs from the queue. The option is there and it's not greyed out, but when I click it, nothing happens. This is only the case for the additional, unwanted Autoplay songs - I can remove the songs belonging to the originally selected album without a problem.

Since yesterday autoplay seems to have been forced on the web player, despite having it turned off on every other device I use. I see no option to turn it off in the browser, is there really not a way to do it?

 

 

Hey @JalapenoMunich,

 

Thanks for posting here 🙂

 

It's a good idea to give these steps a go and log out from everywhere to see if that helps.

 

In case nothing changes, could you send us a video recording of what you're seeing? We'll look into this further.

 

Keep us posted.

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Came here to say this. wth! Every change Spotify makes to its user interface is more and more alienating to me and the way I enjoy listening to music. 

Having the same problem. I hate it. It's making it difficult for me to use this service that I pay for.

I've had the same problem, logged out everywhere and logged back in. Nothing fixes it.

Yes, this is truly so stupid, especially since it has functioned without this forever. I can't use the desktop app on my work computer because it's too slow and the desktop app itself is already kind of broken. Why does the web player just not have access to the settings? Spotify why do you do this!!! 

I logged out everywhere and for a second I thought the problem had disappeared ... but that was only because I was listening via my notebook's internal speaker. As soon as I change to one of the Sonos speakers, the queue is populated with Autoplay songs.

 

Please find attached a video. It starts with me listening via the notebook's internal speakers - no Autoplay songs in the queue. I then switch to one of the Sonos speakers and immediately, the queue is populated with Autoplay songs. I then try to remove two of the Autoplay songs from the queue to no effect. Last, I remove one of the original songs from the queue - works without a problem.

Thanks JalapenoMunich, your video shows exactly the same behavior I experience since a few days back. Difference is that I'm on Mac and play music on Amazon Echo speaker via Spotify Connect. I've also turned off Autoplay on all my devices.

I am having the exact same problem. 


If I listen to music using my computer's speakers autoplay is not on and the album stops when it is finished. If I switch to my Sonos speakers it automatically populates the queue and I can not get rid of the songs in the queue. 


This will happen mid-album as well. If I start the album off on my computer speakers the queue will only contain the remaining songs but if I switch to my Sonos speakers it automatically populates the queue with additional recommended songs. 

 

App has been uninstalled and reinstalled. Computer has been shut down and restarted. Problem still persists. 

 

 

 

 

Yep, mid-album for me too (the video I posted above was taken mid-album). 

 

It's also worth noting that I first noticed the problem on the day I opened this thread or the day before. Not sure if it's the same for others, but that could be an indication that the issue is caused by a recent update.

This has been a recent issue for me too. My speaker is a Bose Soundtouch.

Hey folks,

 

Thanks for reaching out to the Community!

 

Could you let us know which browser you're using and if the same happens when using a different one? Does it persist when using an incognito/private window?

 

We'd also like to know when this started happening.

 

Keep us posted.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Hi, I'm having the same issue.
It ONLY happens when playing on a Google Cast device or in a web player, it does not happen on my Android phone or on my Windows 11 PC.

Example:
1. Playing an album on the Windows. No autoplay as it should be.
Windows.jpg
2. Casting to a Google Nest Mini. Autoplay songs instantly show up in "Next from".
ChromeCast.jpg

3. Change to playing in Web player. Autoplay songs refresh with different songs.
WebPlayer.jpg

4. Changing back to playing back on this computer instantly removes all the autoplay songs.

I tested it with the web player in Firefox, Edge, and Vivaldi and had the same behavior in all of them. So far I haven't found any workaround to disable autoplay in web browsers and Google Cast devices.

Have the same problem on Chrome Version 95.0.4638.54 (Official Build) (64-bit) on Windows 10 enterprise 20H2.

Hello! It happened to me in Google Chrome, but I tried in other browsers (Firefox and Brave) and the same seems to happen.
The problem happens in incognito mode as well, in all three of the browsers I tried.
I first noticed it on Monday 18, but I did not use the web player on the 2 days before.

Seems to be similar. I just tried to remove the autoplay songs from the queue and it doesn't let me do it

Same issue here with Windows 10 desktop app and iOS.

 

Autoplay is toggled off on both devices - I am able to toggle it.

 

Playing a single, for example, will immediately queue up a bunch of songs after it despite Autoplay being off. I can see them in the queue as soon as I start playing the single I came to listen to.

 

It only happens when playing via Spotify Connect (Sonos speakers). If I play directly to the PC speakers, it doesn't queue additional songs. If I play to my Sonos, it queues additional tracks.

Suggested posts