Default Shuffle Off

Default Shuffle Off

This applies to Mac and Windows, 


Start Spotify.


Select something like Discover Weekly - Shuffle is selected.


Turn off Shuffle (I know how to turn it off)


Close spotify.


Open Spotify.


Select - for example Morning Coffee - Shuffles back on.


How do I turn it OFF. Permanantly. I don't want it on by default.


Yes I'm premium, have been for a while.

3 Replies

I also am annoyed that Shuffle On seems to be default. I don't want this and it is frustrating to have to turn off shuffle everytime I play start Spotify. 


I do use shuffle sometimes, but I should not be forced on me everytime I open the app.

How has this not been fixed/answered yet? Same problem for me. Everytime I close and open spotify, shuffle is back on. It's so incredibly obnoxious. Half the time I don't notice it until some random song pops on, or until after I'm 6 songs into an album I've never listened to before...and then have no idea what any of the last songs I've been listening to where. Why is it doing this? What an odd default setting. It's like if spotify defaulted to playing "It's a small world after all" everytime you started it up. Sheesh.


Any advice would be appreciated!


(premium user for 3 or 4 years)

I agree. Shuffle is the worst. It turns Spotify into Pandora. I want to listen to albums, but defaulting to shuffle pushes me into the album on the 2nd song. It's like an unannounced "Spoiler Alert" kind of offense.


Super easy fix, Spotify! It's so easy to switch to Google Play, fix this now.

Suggested posts