My G613 play button.

Solved!
Reply

My G613 play button.

Wackado06
Casual Listener

 

My Question or Issue

 

Ok so. I use G613 gaming wireless keyboard from Logitech. I wanted to play music while playing the game, but when I press the play/pause button on the keyboard, it doesn't work. But my volume and mute button works. And the way to switch or play songs is to close the game and click play from spotify software. If there's any way you can help, thank you.Image result for G613

This is what the keyboard looks like. And the button I'm talking about is on the top right side. Also I wasnt sure where to post this.

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

CryticalAce
Community Legend

Hey @Wackado06,

 

That's a shame! I have an idea, this works in a few ways, a work around and a way to get more info so we can troubleshoot this a bit better for you!

 

If you haven't heard of Auto Hotkey yet, I'll give a quick explaination as to what it is and how it works! Basically Auto Hotkey (I'll refer to it as AHK from now on) is a little programming language that you can use to create keyboard macros (especially handy if you are like me and have no predefined macro keys on the keyboard or media keys. Now don't fret, you don't have to install it if you don't want to, it will easily run off your desktop, just means you'll need some extra steps.

 

So now for the fun part!

  1. Head to this link to go and get AHK, however suits you best
  2. Once you have AHK extracted (or installed) create a new text document and name it ***.ahk (replace '***' with anything you want.
  3. Then open the text document in any text editor or coding tool (my favourites are VS Code and Notepad ++)
  4. Enter the following code without the quotes: 'RCtrl & Space:: Media_Play_Pause (You can make the hotkey anything, I would have it set as this as I know that it works for me when using Spotify)
  5. Click Save and open the text file
  6. You will see a little green box with an A in it in the bottom right corner of your screen, you can use this to close or pause the script by right clicking it.
  7. Now open Spotify and select a track if one isn't queued already and press Right Control and Space and it should pause and then play.

Let me know if that allows you to control Spoitfy (especially from other windows) and we will go from there! 🙂

 

Thanks!

View solution in original post

5 Replies
Solution!

CryticalAce
Community Legend

Hey @Wackado06,

 

That's a shame! I have an idea, this works in a few ways, a work around and a way to get more info so we can troubleshoot this a bit better for you!

 

If you haven't heard of Auto Hotkey yet, I'll give a quick explaination as to what it is and how it works! Basically Auto Hotkey (I'll refer to it as AHK from now on) is a little programming language that you can use to create keyboard macros (especially handy if you are like me and have no predefined macro keys on the keyboard or media keys. Now don't fret, you don't have to install it if you don't want to, it will easily run off your desktop, just means you'll need some extra steps.

 

So now for the fun part!

  1. Head to this link to go and get AHK, however suits you best
  2. Once you have AHK extracted (or installed) create a new text document and name it ***.ahk (replace '***' with anything you want.
  3. Then open the text document in any text editor or coding tool (my favourites are VS Code and Notepad ++)
  4. Enter the following code without the quotes: 'RCtrl & Space:: Media_Play_Pause (You can make the hotkey anything, I would have it set as this as I know that it works for me when using Spotify)
  5. Click Save and open the text file
  6. You will see a little green box with an A in it in the bottom right corner of your screen, you can use this to close or pause the script by right clicking it.
  7. Now open Spotify and select a track if one isn't queued already and press Right Control and Space and it should pause and then play.

Let me know if that allows you to control Spoitfy (especially from other windows) and we will go from there! 🙂

 

Thanks!

View solution in original post

Wackado06
Casual Listener

Thank you.. I’ll try it out.

Peter
Spotify Legend

Hey @Wackado06.

 

Did you have any luck with the steps that @CryticalAce provided you with?

 

Keep us posted,

 

P

rishipkothari
Visitor

Had the same problem here, turns out it was Chrome that was the culprit. Little digging uncovered that Chrome 74 had a new feature that allowed Chrome to capture the keys for Youtube etc control via media keyboard, and did not send those signals onto other applications. A flag can be set to disable this. Open this link in your Chrome browser:

 

chrome://flags/#hardware-media-key-handling

 

Disable the flag. I found that I also had the Google Play Music App installed in Chrome and had to remove that as well. After doing these two things and restarting chrome, my Logitech G613 keyboard's media keys were functional again! Hope this helps without the AutoHotKey workaround. 

WilPower
Visitor

+1 for this response. I disabled Google Play Music and the Chrome media key setting, and my media keys started working perfectly. They even started working in other media applications.

SUGGESTED POSTS