Announcements

My Web Player Keeps Skipping Songs

My Web Player Keeps Skipping Songs

Hello, 

 

For the past week, I've been trying every single day to get my Spotify web player to work. Every single time I go to play anything, a playlist, any song, or even any featured playlist, it just skips and skips and skips until it hits an ad. I've done everything from logging out of all accounts to see if there was an interference. I've restarted and restarted my device. I've even disconnected my device from the internet time and time again. No matter what I do every attempt is heedless. If anyone can help me I'd greatly appreciated it. 

 

Reply
8 Replies

This is happening to me too. I have tried uninstalling another version of flash too from Windows.

I also get the same thing, except the ad doesnt play and it just gets stuck there.

 im having the same exact problem and i dont know what to do

I solved the issue by installing the spotify app in the windows store (I am on Windows 10).

same issue here (premium account), web player skipping tracks since some days, no sound is played. Web player was working fine for the past few weeks

I've got the same issue, I can't download the desktop client on my work computer but I'm allowed to use the web player. Ever since this happened I've had to actually talk to my coworkers - what a nightmare!
On a serious note, someone needs to check with us and try to troubleshoot as I really miss my music at work.  

PS: What I've tried so far:

- Clear all cookies and cache.
- Always Allow Flash.
- Using Spotify Connect to swap between the web player and my phone repeatedly.
- Incognito mode.
- Logging in via different means, eg. Facebook/email.
- Checking my audio device drivers (both speakers and headset).
- Trying to unplug the usb headset and play through laptop speakers.
- Using a VPN.

Nothing has worked, the songs keep skipping.

I surmise and guess that the issue is related to the account itself. On my shared account, I have my facebook account linked. The facebook account's older account email is no longer in use and I changed it. Spotify still reflects the older email even though I went through the link in Spotify to change the accuont name. The user managing the fail account also has this issue. I bring this up because I have seen people solve this issue by creating another account which isn't feasible for me. Overall, this is just something that is "off" about the account that I am guessing could be causing some conflict. Mine was working fine too weeks ago.

This issue has cropped up repeatedly over the years the internet tells me. Most people say it has to do with your sound card,  usually drivers or output settings.

For me what fixed it was instead just not plugging my speakers into the headphone jack until after I hit play the first time.

Suggested posts