Next song won't load / freezes (Multiple Devices) on one network

Next song won't load / freezes (Multiple Devices) on one network

ShortRaver

So I have a really unique issue where a number of my devices will only complete the playback of one song before freezing (or taking upwards of 5 minutes to change to the next song). What makes this particularly interesting is that it only occurs via one of my routers on my network.

 

To explain further:

 

I run two routers on my LAN: A DSL router with DHCP and wireless AP, and a cable router without DHCP enabled. All Spotify devices are assigned to my DSL router via DHCP. However, playback essentially fails after the first song (unless I skip the song early). This includes my Sony Android TV, PlayStation 4 and Bose SoundTouch 20. This does not seem to happen with my iOS devices (iPhone 6S+ and iPad Air) and via the desktop application on one of my PCs.

However, when I assign the devices to my cable router statically (DHCP is off), songs will change successfully with no issue.

 

I have tried just about everything:

 

  • Signing out of all devices
  • Logging in via username instead of Facebook / Spotify Connect
  • Reducing the stream quality
  • Reinstalling the application on each device

I've also tried the following network changes:

 

  • Disabling the cable router
  • Resetting DSL router to factory defaults
  • Static IPs on the DSL router
  • Using ethernet and wireless connections
  • Port forwarding
  • Trying the MTU setting some have suggested for the PS4
  • Using Google DNS settings

 

My DSL connection is rock solid at 20/2 whilst my cable connection runs at 100/2. I know the cable connection is better, but my preference is to have Spotify devices running via the DSL.

 

If anyone can help, it would be much appreciated!

Reply
0 Replies

Suggested posts