No longer able to login to Spotify on ONKYO AVR TX-NR709

No longer able to login to Spotify on ONKYO AVR TX-NR709

musicisoxygen

Have been happily using Spotify (on Premium account) on Onkyo TX-NR709 for a few years now. Then I recently decided to share a new playlist on Facebook. Was asked by Spotify to connect to my Facebook acccount which I did. The shared playlist came through on my FB.

 

Horror then hit. I then noticed about a day later that the Spotify playlists on my Onkyo AVR was not updated. I decided to log out and log back in to Spotify on Onkyo and had problems - Login error. Tried chaning passwords on Spotify and re-tried a few times. No luck. Used the ONKYO reset (pressing the VCR/DVR and ON/Standby buttons together) to clear and tried to re-login to Spotify. No luck.

 

While doing above, all the while, I could continue to use Spotify on my notebook and mobile. I even tried disconnecting my Spotify acccount with Facebook. No luck still.

 

Any help will be greatly grealty appreciated. Will miss playing Spotify through my home audio system. One of the reasons why I signed up for Premium. HELP!!!!

Reply
6 Replies

r3w2000

I'm having similar problems with my 709 with slight variations.  I never connected or accessed Facebook though Spotify.  I can log in through the receiver but Search doesn't return any results and all folders/playlists are "empty".  I deleted a few playlists using my phone but the changes are not reflected on the receiver.   I even opened another Spotify premium account, same thing.  

 

I've emailed Spotify support with details and, although they've responded, I'm getting troubleshooting 101 responses that aren't considering our set up ("upgrade OS, upgrade APP, upgrade firmware, etc. etc).

 

I have a hunch our receivers have reached their "sell by" date as far as Spotify is concerned.

 

 

musicisoxygen
Yup. Spotify asked me to try the following: Check you have an active internet connection. You made your account with a username and password, enter those (not the email address) and tap LOG IN. Close and reopen the app. Restart the device you’re using Spotify on. Which I already did before with no luck. They also suggested that I contact ONKYO support should above not work. I just wrote to ONKYO support. Let’s see.

ross3wilson
They just pointed me to Onkyo as well but that's where I started. I passed Spotify the following info -

"I actually just set up a 2nd premium account today for testing. I wanted to see if the issue was account related. I've been logging in and out of both accounts using my Onkyo receiver. I also just set up single playlist "test" under acct 2 using my phone.

This is the current status using my Onkyo receiver -

Account 2 - can log in and out. Can access and play songs in What's New. Do not see new playlist. Cannot search.

Account 1 can log in and out. Playlists are not accurate (I deleted some with phone and they still show up on Onkyo). Cannot access What's new. Cannot access playlists or search. By that I mean playlists say they're empty and search never returns results.

I have also logged off all other devices except for Onkyo. No difference."

This starting to feel like it's going to require a firmware change and, given the age of our machines, I'm not holding my breath.

ross3wilson
2nd update - this morning acct 2 worked, briefly. I logged out and back in again and it stopped working. What's weird to me is that it seems that with the Onkyo UI it acts like you're "registering a new device" when you're simply logging in.

ross3wilson
I left for a few days. When I got home last night my new acct (account 2) mentioned above is working. I'm not even going to try the old account, I'm just cancelling it.

To me it really feels that every time you log out and back in again through the Onkyo it's "registering a new device". So I'm leaving it until it stops working again. This one of those things that neither Spotify or Onkyo are going to care about at all.

musicisoxygen

Looks like you are right. It just corrected itself. I was travelling couple of days and just got home. I tried logging in to the same Spotify account which I had problem with earlier (I didn't get a chance to create a new one) and to my surprise the log in was successful and my latest playlists all came in. Something was flaky earlier on. We will never know whose problem it was - Spotify or ONKYO. Lesson learnt for this type of problem - to leave it for awhile and try again much later. 

 

Thanks for working with me on this Ross3Wilson. BTW ONKYO support never responded at all. 

Suggested posts