Announcements

No sound through Heos and Spotify Connect

Solved!

No sound through Heos and Spotify Connect

Right, I've been having a big problem with my Denon Heos 1 speaker and Spotify Connect.

 

Initially, my Heos speaker was connected to my wifi, and I could find it on Spotify Connect, then I would go through the process to play through the speaker, but no sound would come out the speaker. The track would progress along the timeline as normal, but it was as if I had muted it (I hadn't on Spotify or my speaker). However, when I pressed pause, the track timeline would reset to the beginning of the track. Further, the Heos app couldn't find the speaker.

I contacted Denon, and they have provided numerous solutions, I have since managed to connect to the speaker through the app. I can play music through any service: Deezer, Tunein Radio etc. However, I still cannot play using Spotify. The only difference now is that when I pause, the track timeline pauses as it should. There is still no music being played.

 

I have soft and hard resetted the Heos speaker, changed network settings etc., and it appears the problem with the speaker is solved. I am using a Macbook Air and iPhone 6 on the latest OS. I have uninstalled the Spotify app on both, restarted both devices, reinstalled the Spotify app, then restarted both devices again, logged into Spotify on both, and the problem still remains. Yet I can still play music using any other service.

 

I have recently gone from Spotify student premium to Spotify family, so I have premium, but that's the only thing that has changed, I'm not sure how this could have affected it.

 

I have restarted my router (BT Homehub 5), I have checked all the settings for it, turned off and on again the UPnP settings.

 

Anyone have any solutions before go insane from a lack of music in my life?

Reply

Accepted Solutions
Marked as solution

Thank you all for hanging in there and having the patience to wait out this storm (3 months of it) regarding Spotify Connect on the Heos systems. We are glad to finally have been able to resolve the outstanding issues together with Denon on their integration! I am considering this ticket resolved and we will be holding an internal incident retrospective on this.

We have not been able to reproduce Daily Mix playback issues on our end. Could someone please open a new topic on the behavior and there describe in detail what happens? Cheers all, enjoy the music.

View solution in original post

130 Replies

Hey @tgbrock

 

Thanks for coming to the Spotify Community for help.

 

Could you check if you get the same issue with a different WiFi network? 

 

Let us know how it goes.

 

Anyk17

I'm not able to try it on another network unfortunately. I have reset my router, and it is shown as a connected device on its homepage.

Thank you for your advice.

I will make an effort to change my router (now I have Thompson TWG870U).
I will inform you about results.

Paweł Lula

The question is if the Heos device haver problems with mDNS or not (routers can have ). Could you please use a zeroconf browser to see if/what the speaker responds on the network. Use for example either Discovery on iOS or Bonjour Browser on Android and look under the service _spotify-connect._tcp you should be able to find Something similar to "Denon Heos 1". And clicking on it should give you the ip, port and CPATH. If you find your Heos device there, could you please open a webbrowser and go to IP:PORT/CPATH?action=getInfo and post the response here? If you don't find anything under the _spotify-connect._tcp service then either your router or Denon has a problem with the zero configuration network in your environment.

Hi jokkon,

thank you very much for your letter.

I have two speakers. Below I put info about them.


My first speaker:
{"status": 101, "statusString": "OK", "spotifyError": 0, "version":
"2.3.0", "deviceID": "c55c5eac1425934ea557ac129df7ad0fa00011a2",
"remoteName": "Sypialnia", "activeUser": "pawel.lula", "publicKey":
"gDPJ1G71jRxqxZHET/t081EF5cQ4IR/wE0WCeqTRtAb72OAooAqn8RdUnVTfxGPAI7eph69CDoamD15i91TutfrDvw7ALOUplwg7bjM3MAuWSwjimOoiPDNRdDPz8n0y",
"brandDisplayName": "HEOS by Denon", "modelDisplayName": "HEOS 5",
"libraryVersion": "2.8.71-g9919e10f", "resolverVersion": "1"}

My second speaker:
{"status": 101, "statusString": "OK", "spotifyError": 0, "version":
"2.3.0", "deviceID": "abf481939a2535e25f0dec7b928eaae7e892c2a1",
"remoteName": "Pokój dzienny", "activeUser": "pawel.lula", "publicKey":
"WgJ1WbkQVwYYN7SNgcuQ3tkOC2PyRaorzCE14L4h+XVaQ08jcKJJiF1dPYrfsiXvGQ3xz+fZHKo0Rc5EfIcYMEEu1g+dYgTxQHeCZID1ENaZTELAz9JEcfAOPG38KxTe",
"brandDisplayName": "HEOS by Denon", "modelDisplayName": "HEOS 5",
"libraryVersion": "2.8.71-g9919e10f", "resolverVersion": "1"}

I run intune Spotify service on the first and inTune radio on the
second. Everything was ok for several minutes. After it speaker with
Spotify stopped and it was impossible to start it again (from Android
phone and from laptop computer). Then I rebooted my router. After it I
saw only one speaker in my Spotify application (on laptop). In "Bonjour
Browser" I saw both speaker - but with the same IP addresses. After one
or two minutes Spotify stopped again on the speaker. And then in
"Bonjour Browser" I could see only one.

Could you help me with this problem.

Best regards,

Paweł Lula



I just Got the same problem.
No matter what I do - Spotify connect and no Sound. Everything Else plays.
The reason for buying Heos was to use Spotify connect. This is bad. Arrgghhhh

same problem here for about a week know.

 

spotify plays for a while and suddenly it stoppes, i have to take the power of the heos sound bar and than it plays agian.

 

seems like a spotify problem because all other music streams work pefectly please solve problem please. 

I have had the same problem for about week or two. Spotify looks like it's playing but no songs from my Heos speakers. When I pause, track progress resets.
Other sources that I've tried work on my Heos. I've noticed that if I connect to another source and start playing something, then go to Spotify and start streaming, everything looks OK in Spotify, but the music from the other source continues and if I check the Heos app, it still shows that other source.

Hello,

 

I have the same problem for a couple of weeks.

I have two heos 5 speaker and I manly want to using spotify, but It is not working from the Android phone or from computer. 

 

Please update for a progress or solution

 

I also have this problem and it is SO ANNOYING!!. Paid $400 for a Heos 5 to use with my Premium Spotify and I get no sound out of it at all. It works with everything else but Spotify connect.

Exactly the same problem. I have just recently purchased a HEOS 7. Every time I hit the volume button on the HEOS the song almost goes back in playtime. But no volume. It says it is connected. The blue light at the base of the HEOS indicates it is connected but still no volume. Every now and then it connects with volume but then it will stop at the end of the song of a playlist and go mute again....and again......and again!! Spotify and HEOS have issues. Not happy with either at the moment

Dear Friends,

thank you very much for your all posts.

I have noticed, that all people who have similar problem:
a) use different version of Heos speakers,
b) use different routers,
c) have very similar symptoms with Spotify and no problems with other
sources.

In my opinion it seem that it is a software problem which should be
solved by Spotify. I hope that software engineers from Spotify will work
hard and will be able to remove all problems very quickly. I am
convinced that all members of our community will be ready to test new
updates.

Dear Spotify! It is worth to fix this error and have clients who are
satisfied and have good opinion about your service! Trust me!

Best regards,

Paweł Lula
Poland



Good that I found this topic. I do have exactly the same problem with my Denon HEOS SOUNDBAR and HEOS 5 (latest Firmware) since around 2 weeks - before I had no problem. It definitely got nothing to do with the Router/Network etc. Restarting router, HEOS devices doesn't help.
I'm able to connect to my speakers/group of speakers, but no sound. When I turn up or down the volume, the status bar of the song jumps to the beginning. I'm 100% sure that this is a Spotify software issue. Tested this on two Android smartphone with latest app versions of Spotify/HEOS. No problem via TuneIn, Play from local device though.
Please go ahead in finding a solution.

Greetings

I reset my speaker once again and it worked for about 5 days, perfectly, no issues at all!

 

It then randomly stopped! So I've gone into my router's settings and added port 4070 in the port forwarding, it then worked for about 4 minutes before randomly stopping.

 

I then restarted my router and it worked for 2-3 minutes, it's since stopped working.

 

I'm seriously considering moving to another provider, luckily Denon Heos is compatible with a few others so I'm not just stuck with the poor service being provided by Spotify here.

Hey all,

 

Suddenly it is back to work for me too. I didn't do anything (even not a reset), but trying to play again from my Android phone.

 

I think they fixed it (but didn't say anything?)

Please check it....

My HEOS 7 plays both on the 2,4Ghz WiFi and the 5Ghz WiFi, but there is problem with SpotifyConnect. TuneIn works flawlessly on 5Ghz WiFi but SpotifyConnect don't 

any one else has this experiences? And does any one got some tips.

 

 

If it's happening to me, and to others, I'm wondering if it really is a wifi issue. The network doesn't drop. Just the Spotify connection to the Heos speakers. I'm about to quit Spotify, sell my Heos speakers, go to Apple Music and Sonos. I've been battling this issue for four months. Others have too.

Nothing has been fixed. This is still an issue.

Keeping things short:
- Pls read the posts carefully, this issue started over two weeks ago out of nowhere.
- It's not a WIFI issue!

Pls guys, fix this Spotify Connect issue and post your feedback of your latest analysis!

Suggested posts