PS4: Cannot connect to the server

PS4: Cannot connect to the server











My Question or Issue

I cannot use Spotify on my PS4. When I open the app, it loads for a moment before displaying an error message that reads "Cannot connect to the server." My PS4 also no longer appears in my devices list when I attempt to connect from my phone or computer (all of my devices are on the same wifi network.) I've seen a few other posts about this issue and have repeatedly attempted all the "solutions" listed to no avail. I have:

  • Uninstalled & reinstalled the app on my PS4
  • Un-linked my PlayStation Network account from my Spotify and then re-linked them
  • Signed out of and back in to both PSN and Spotify
  • Restarted my PS4
  • Restarted my router
  • Attempted to connect via hotspot to see if it was a problem with my network (I still received the same error message.)

Every other app on my PS4 is working with no issues whatsoever, so I do not believe it's an issue on their end. I do not use a VPN or proxy, and as stated above have restarted my router and used a different network entirely via hotspot, so I do not believe this is an issue with my internet either. Any help you can offer is appreciated. It is admittedly very frustrating to pay for a service that so rarely functions the way it is supposed to.


2 Replies

Hey there @klflavin,


Thanks for reaching out about this and welcome to the Community!


We appreciate the time you've taken to go through this and for sharing all the steps you've tried.


There's something else we could try here - could you set the MTU value in your PS4's network settings to 1450 and let us know if that does the trick?


Also, make sure there aren't any pending system updates in your PS4.


If the issue persists, could you let us know when it started happening and if it was after a specific event, such as an app or software update?


Keep us posted. We'll be on the lookout.

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.

This worked for me. (PS5)  Options Button > Advanced Settings on the network name and you can edit the value there.

Suggested posts