Announcements

Playback Restricted Devices Greyed Out

Playback Restricted Devices Greyed Out

Wesmond1
I cannot connect my Spotify to echo devices anymore. All devices greyed out and read 'Playback Restricted'. Have tried deleting and reinstalling Spotify and Alexa apps, clearing cache, resetting wifi, unplugging and re-powering echos. All to no avail. Work-arounds very welcome
Reply
65 Replies

cjweekes

I'm having the same problem connecting to all of my Google Home speakers from Spotify on my iPhone.

Heofenum

Same here. Very annoying. 

Heofenum

Ok, so upon further exploration my issue seems to be related specifically to the This American Life podcast.  I can only play it on my phone.  All other devices are greyed out and labeled “playback restricted.”

Jeremy

Hi there folks,


Thank you for reaching out to the Community. This seems odd so let's take a closer look into this.

 

Would you mind making sure that there's no old cache files causing this by following these steps? 

 

Also,  could you try to stream from a different device with your account, and if that doesn't work, try another person's account, to see if that happens there too?

 

It would also be great if you can let us know if this occurs while trying to play music, podcasts or both.

 

@Heofenum, just to confirm, can you listen to other podcasts?

 

We'll keep an eye out for your replies 🙂

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

CinciAmy

I cleared cache, uninstalled, waiting 5 minutes, reinstalled, and I still have playback restricted on my echo dot.  Please help!

Vasil

Hey @CinciAmy!

Sorry to see this has happened to you?
Are you trying from a desktop device using a wired connection :?
If so, turn the speaker on and let it play anything, if all works well, this should fix your playback issue.

Let us know how it goes! 🙂

VasilModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Tto

Having this problem, too.   Was trying to play Campin by the Okee Dokee Brothers.  Will cast to google speaker groups but not Echo speaker groups, Playback Restricted.  Will sent you individual speakers.

Alex

Hey there @Tto,

 

Thanks for the post.

 

Can you cast to individual speakers from the Echo group?

 

Looking forward to your reply.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

leuk0cyte

I am having the same issue with two new Amazon echo speakers. They appear grayed out on the Spotify app and have the text "playback restricted" displayed next to them. Resetting account, reinstalling speakers, doing the other things listed in this thread have not helped. Very frustrating since the speakers primary purpose is to play Spotify. Moderators, can you ask your coders for the app what are the triggers to display the text "playback restricted" so we can understand what is triggering this? The text didn't come from the ether. This is a feature of your program. 

rwillcox

I'm having the same issue. I set up a brand new Echo dot a few hours ago. At first, it played fine but after a few hours I came back to the Spotify app and the device is grayed out, and "playback restricted" is displayed underneath it. How can I remedy this?

HB783

I’m also having this problem. I have three echo dots and one by one they have all started to become greyed out with the message “playback restricted”. This happened once before to one of my speakers and it randomly fixed itself but never to three at once. Also my echo show still works for some unknown reason. I can’t play from the speakers either. This is for any of my music 

jburn731

Factory reset your Echo by holding the mute microphone button and the volume down button at the same time. Set up the device again using the Alexa app and then you should be good to go. It’s certainly a bug on either Alexa or Spotify software, but that’s the work around for now.

ThatAmandaPanda

This is happening to me too. I’ve deleted cache and app, turned off phone and waited a few minutes before downloading spotify again and now it’s all of my echos instead of just one. This sucks. I only buy these echos to listen to music.

ThatAmandaPanda

That did not work for me

Coyler3259

I'm also having this problem. New Echo Dot worked ok initially but a few hours later has 'Playback Restricted' but Spotify still working fine on original owned Echo. This has to be a Spotify software issue, tried rebooting etc Echo but hasn't solved the problem

LethalCupOfTea

I’ve been trying with OGoA podcast via Spotify and I added 2 new Echo Dots. 
From the Alexa app I can play the podcast from each Echo Dot by itself, but not as a group. 
Going through the Spotify app I have a very limited selection of individual Echo Dots but it gives me one of my groups that I can connect to. 

LethalCupOfTea

Also cleared both apps caches, uninstalled and reinstalled the apps. No change. 

nazariof

Not working for me on my PS4. Device appears greyed out and saying "Playback Restricted"

JonyMateos

I'm having the same issue with my Echo Dot 4. I'm trying to play a song from the Spotify app on iOS but the Echo Dot appears greyed out and it shows Playback restricted. 
Looks like a software issue, I hope it can be solved soon because it's one of the main features…

Suggested posts

Env: prod