Playlists on Echo?

Solved!
Reply

Playlists on Echo?

ConfusedEchoUsr
Casual Listener

I am a new Premium User.  I have an iPhone 6, a Windows desktop, an iPad, and an Amazon Echo.  I have had other music services in the past, such as Deezer, Amazon Prime, and Apple music.  But I signed up for Spotify because of its support for Amazon Echo.

 

I am having a very hard time trying to navigate the mess that is Spotify.    I would like Spotify to learn from my listening habits and suggest music for me to listen to.  Deezer did this brilliantly and effortlessly.  You could just ask it to Flow and it would play its best guess about what you like or don't based on your likes and listening history.   Spotify seems totally lost.   You can't even like songs from what I can see.  Or else you can, but only on certain devices and when playing certain streams that I haven't found yet.  You certainly can't do it on Echo.

 

So I am looking for a way to get some playlists that are to my taste based on my listening history and play them on Echo.  Or if that isn't possible, to at least search for some playlists on my desktop or phone, add those to my library, and then ask Alexa to play them.  Even this seems impossible.  I search for playlists on the Desktop, and you cannot add them to your library.  Instead you have to "Follow" them, whatever that means, and then they aren't in your library, and they certainly aren't accessible in Echo.

 

In an act of desperation, I created a playlist of my own called "Test" and added one song to it, and then tried to play that on Echo by saying "Alexa, play the playlist Test on Spotify".  This resulted in Alexa playing something totally different.

 

I do not want to create my own playlists.

 

Help!

2 ACCEPTED SOLUTIONS
Solution!

Alec1999
Newbie

I don't know if there was an update or if it's solved now but I'm just a new user and for me it works like this "Alexa, play the playlist 'amazon' from Spotify" the amazon between ' ' is my playlist's name

View solution in original post

Solution!

Farleyfeatures
Regular
As I've said several times before, you need to have a paid - for Spotify account. Create your playlists, then tell Alexa 'Alexa, play playlist '. You can then tell her to skip track,  pause, resume etc. 
Geoff. 

View solution in original post

37 Replies

kerry17
Regular

I have a premium spotify account. I have linked it to my echo as the default music service. Anytime I ask alexa to "play my XX playlist" the response is "I cannot find XX in your music library. Amazon account is UK. Spotify account is UK. And yes, I have turned it off and turned it on again, de registered and re registered, unlinked and relinked.... still the same problems - has anyone found a way of getting Alexa to find the spotify playlists in their spotify library??

 

CJ42
Casual Listener

For me it was a matter of changing playlist names until one worked in Alexs play  "playlist name" on Spotify.

 

 

Solution!

Alec1999
Newbie

I don't know if there was an update or if it's solved now but I'm just a new user and for me it works like this "Alexa, play the playlist 'amazon' from Spotify" the amazon between ' ' is my playlist's name

View solution in original post

sherril61
Casual Listener
 

sherril61
Casual Listener

I had an issue playingmy own playlists but then realised that although I had linked my spotify account I hadnt made it the default. you need to go to settings in the alexa app and make spotify the default for music. no problems after that. jI ust say alexa play playlist 'whatever.' 

Synker12
Newbie
I just say (alexa... on my spotify playlist, play "my music" , "jonathans songs" , "my sleep songs") and it plays it just fine and any other playlist i have on there. You just have to speak clearly and not too fast and remember to annunciate your words. It sucks and its very specific but in a way it helps with your pronunciation and you annunciation.

Legally_KLee
Casual Listener
Lol. I'm from Texas. Alexa doesn't like my accent at all, regardless of how much I try to annunciation.

Farleyfeatures
Regular

Elocution lessons? ;o)

Samueloufc02
Casual Listener
You need to set Spotify as your 'default media player'. To do this go to the Alexa app > Settings > Music & books > select default music player and click on Spotify. Hope this helps!

aoshea99
Casual Listener
I set it as my default music player when I set up and Alexa still doesn't play My Playlist!!! Very disappointing

Samueloufc02
Casual Listener
Have you tried checking in Settings? Sometimes when Alexa gets an update it changes

Farleyfeatures
Regular

I have set Spotify as my default music server.

I have to say "Alexa, play playlist 'Whatever'" and she responds with "playing playlist 'whatever' from Spotify".

Apparently you have to have a paid for account - if you are using a free account it won't work. 

Samueloufc02
Casual Listener
Yeah, I have a premium account I share with my mate that it works with

aoshea99
Casual Listener
Yep.. I have a paid account....

##- Please type your reply above this line
Annette O'Shea

Debbiep1
Newbie

You need to make Spotify the default music account on the echo for this to work.  It is auto set to amazon 

Solution!

Farleyfeatures
Regular
As I've said several times before, you need to have a paid - for Spotify account. Create your playlists, then tell Alexa 'Alexa, play playlist '. You can then tell her to skip track,  pause, resume etc. 
Geoff. 

View solution in original post

kerry17
Regular

I have a premium spotify account. It is set as the default music service for my amazon echo. Alexa ALWAY says it cannot find my xx playlist in my music library...... or it will play some random playlist from spotify - had zero success getting it to play my playlist. Had a 30 min phone conversation with Tech Help at Amazon - they had no solution (tried all the delete it re install it etc etc, changed the playlist names, removed the capital letters - nothing works) - anyone found a solution? Where is the fault with spotify or amazon?

ciscosurplus
Casual Listener

I have read the whole thread, I have Spotify premium, I am using the phraseology above and it is my default music service. 

 

When I link to my USA alexa account it works but not my UK one. 

Farleyfeatures
Regular
Then I can only think you have something wrong in your settings. 
I have a premium account and it works fine. And I'm in the UK. 

ciscosurplus
Casual Listener

Thanks, 

 

that rules out the geographic, did you have a us alexa account also? That the only other thing I can't think my amazon account is linked and the us alexa account I had before echo came to the uk. 

SUGGESTED POSTS