Help Wizard

Step 1

NEXT STEP

Podcasts Featuring Music, Skipping Songs

Podcasts Featuring Music, Skipping Songs

Plan

Premium

Country

United States

Device

Android, Windows, possibly all devices

Operating System

 

 

My Question or Issue

I am a podcaster who uses Anchor to publish episodes to Spotify that feature music tracks. I have run into an issue with the most recent episode where songs are getting skipped when going from one segment to the next. The music itself is available and plays on Spotify with no problems, and if I scrub forward or skip to a music track, it plays normally. The issue only occurs when transitioning from a spoken podcast segment to the music track. I have tried removing the episode and republishing it, but nothing seems to work and I am not the only user who is experiencing this problem with this particular episode. It is happening across multiple platforms as well (Android 12 and Windows 10 at the very least). I'm completely stumped here. Can I get some help?

Reply
28 Replies

Hi @mattdklein,

 

Thank you for reaching out to the Community!

 

We'd like to look further into this. Could you provide us with a screen recording which shows this in action?

 

Keep us posted.

 

Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

I checked again, and it seems the issue has been resolved because
everything is working. Thank you for reaching out.

Hey again @mattdklein,

 

Awesome! Glad to hear everything worked out for you.

 

Don't hesitate to reach out again - the Community is always here if there's anything else you need assistance with.

 

Take care!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

I uploaded another episode, and it's having the same bug I described before. I've taken a screen recording of the issue for your reference.

This issue has also started up again with the previous episode that was described above. It affects every OS— Windows, iOS, Android.

For what it is worth, as a user (not a podcaster) I have been having this issue also. It has been occurring on the ChillDaBeats podcast, so it is not just an issue with this particular podcast. It has happened on  multiple episodes.

I feel bad that this has happened to other podcasts. The issue has become so frustrating, I'm actually considering switching up my format and ditching the Spotify exclusivity entirely.

Hey there folks!

We appreciate that you're keeping us posted!
And thank you @mattdklein for uploading the video.

 

As we couldn't reproduce the issue on our end, could you let us know on exactly what devices this is happening and the OS they are running on?
We'd also appreciate you checking your Spotify version and letting us know what it is.

Any podcast links will also come in handy.

 

Many thanks.
Cheers!

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Thank you for your response. The operating system is most certainly not the issue, as I use an iPhone (running iOS 15.4), an Android (Android 12), and Windows 10 on multiple devices and I am experiencing the same problem on every device. I have updated to the latest version available on the App Store and Google Play. I have tried logging out and back in again, clearing my cache and downloads, uninstalling and reinstalling... Nothing corrects this problem. The first occurrence of this problem was uploading this episode on February 7 (https://open.spotify.com/episode/1daG9Y6D0TTcDGBbh3dtYc?si=c80ab2b854734f14), when I first reported the problem. It oddly seemed to correct itself after a couple of days and I considered it a weird one-off bug. On March 23, I uploaded this episode (https://open.spotify.com/episode/0qWQ2KSKnDwrxjnjRzfgtn?si=52a8d72a0b894da7) and now both episodes have the same issue of skipping songs. The only possibility that I can think of is that it is somehow a bug related to an episode we put out on March 21 of last year that featured music by Joni Mitchell (https://open.spotify.com/episode/0MDaZGx4deZzMJfbhTSU2J?si=6855ed53b6294a10), who has since pulled her material from Spotify. I have no idea how that could be the cause of this problem-- but considering it now plays in exactly the same way (skipping over the songs since they are no longer on Spotify), I have to believe the two things could somehow be related.

I recently faced the issue that Spotify only plays the moderation part of podcasts both on Android and Windows.

 

To explain my problem a little bit further:

When playing a Podcast, most of the time the first "track" is a moderated part but if I'm looking at the length it, after the elapsed time it starts with the next part of the moderation instead of playing the actual song. To exclude that the problem is device side I'm getting the same effect both on Android and Windows. If I skip the part it plays the song normally but after that it plays the next part of moderation and then starts again to skip songs.

 

Does anyone else experienced something like that?

 

 

Plan

Premium

Country

Austria

Device

LG V30, Desktop

Operating System

Android 9, Windows 10

Hi @DerKanzler1721,

 

Welcome to the Community and thanks for reaching out!

 

Could you provide us with a short video which shows the issue you described in action? That way we can get a clear understanding of what's happening on your end. Feel free to also let us know what troubleshooting steps you've tried so far so we avoid repeating them unnecessarily.

 

If you haven't already, try reinstalling the app on both devices by following the steps here to see if that does the trick.

 

Keep us posted on this.

 

Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

I am having the same problem as a listener....the podcast Bandsplain is skipping the songs between talk segments which sucks because...thats the point of the podcast.  are you working to fix this?  I'm running on a mac and iphone 13.

As a consumer of these type of podcasts, I'm having the same problem with Bandsplain, on all platforms. It's worked fine ever since the inception of these type of podcasts, but in the last 2 weeks it continuously skips the songs in podcast. It happens consistently in both the Windows and Android players. I've logged in and out of the Android app, which hasn't helped.

Hello, just chiming in here as I have also started experiencing this over the last week. It happens on macOS desktop app and my Android app, same issue where the songs are skipped. I have tried doing a full uninstall using instructions I found here on the Spotify help pages, then reinstalled. Same issue still happens. There is nothing else I can do really, all my settings are default.

 

I have taken a small screen video of the issue as you requested from DerKanzler1721. You can hear the voice playing for Part 8 of the podcast, introducing the next song. It does not play the next song though, it skips ahead and just plays Part 9 (the next spoken section). This happens for all songs.

I am also a consumer of this style of podcast and am having the same problem of the songs being skipped over which then somewhat negates the point of the podcast format with integrated music segments.

They have worked fine up until last week when this issue began, the problem is the same on the Spotify app on Windows 10, on the current version of the Android app and also via the web player and Linux PC's also so I don't think the issue is device specific or even related in this instance.

The particular podcast that I first noticed this on is https://open.spotify.com/episode/4eyg0Q5kZnUQAqDjhRFfGE 

Like everyone above I have tried all the obvious things at my end, logging out and back in, re-installing the app etc none of which has made the slightest bit of difference unfortunately!

I am both a listener to these types of Podcast, and the host of a show, The Metal Podcast, and noticed the same issue this morning, that the Podcast is skipping songs.  They play if I click on them manually, so they are in the Podcast, and queued correctly, just skipping - this is a terrible outcome and completely kills the whole purpose of the format. 

 

We have guest segments on our show, and one of our main selling points is that we can feature guests music - so the skipping is horrible - especially as each segment segues to and from the music.

 

Here is a link to the show -  https://open.spotify.com/episode/5Gw7NWXFe70MgbjOLk04L5?si=85b7iGYLR_GEhXgsgQSHoA

 

What I have noticed is that when it skips the song and goes to the next part, it actually lights up the song, as if its playing, but in fact, its playing the next voice segment.  I have screenshotted this - so what should be playing is the song sail ... it indicates its playing, but Part 4 is actually playing, and you can see this by the white line played status indicator.

 

Phone type is Samsung Galaxy A32 5G, model SM-A326B (with latest updates), Spotify Version 8.7.18.1138

 

 

 

Screenshot_20220406-102003_Spotify.jpg

I had the same behaviour, i.e. the song being highlighted, but the next part being what is actually played (in Android)

I am also a Music + Talk show producer and have had the issue with my recently released podcasts, and wanted to get a status update on a fix. Anchor acknowledged to me that there is a problem somewhere but they didn’t disclose to me whether the problem is at Anchor or at Spotify.

 

Please provide an update to the Anchor community when we can expect a fix. Right now, all our recently released episodes are broken 😢, and we have no idea when they’ll be fixed. Makes it very hard to build an audience.

Hi folks,

Thanks for the feedback so far!

We were actually able to recreate this, but only on accounts that are set to Australia or the UK (no issues with accounts set to any other country). It looks like this may be a regional content issue, so we'll definitely flag it internally, but it would be advisable for the podcasters to reach out to our Podcast team directly as well.

Thanks again for making Spotify better. Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts