Announcements

Podcasts cant be played on my Sonos devices - AGAIN

Podcasts cant be played on my Sonos devices - AGAIN

drakeschmiet1

Plan

Premium

Country

Germany

Device

Samsung Galaxy A40

Operating System

Android 11, Windows 10

 

My Question or Issue

Hi there,

 

In december my Sonos devices no longer recognized podcasts played from Spotify. When I've been connected to a sonos device via spotify connect and tried to play a podcast from Spotify, the device icon has been flashing but then nothing happened.

I already posted a thread in the community: https://community.spotify.com/t5/Other-Podcasts-Partners-etc/Spotify-Podcasts-can-t-be-played-on-Son...

Spotifys solution was, that i delete my account and transfer it to a new one. As im the holder of a family account, thats not really practible. Now the same problem occurs AGAIN: When I try to select a device from my phone or desktop Spotify app while playing a podcast, nothing happens, almost like the app didn't even recognize the input.

 

  • I have uninstalled and logged out of Spotify on all of my devices.
  • I have unlinked and relinked the Spotify skill fromSonos
  • I have removed and reset all of my Sonos devices.
  • I have reset my network.
  • I've toggled allowing only local devices.
  • I've tried playing maybe 30 different podcasts in case my usual podcasts stopped being supported, but NONE of the podcasts would play.

Any solution?

Reply
9 Replies

Eni

Hey there @drakeschmiet1

 

Thanks for reaching out about this here in the Community. 

 

Would you mind asking a friend or a relative to log in to their account in your phone to check if this happens using a different account as well?

 

On another note, we suggest that you check if the firmware of your Sonos speaker is up to date.

 

Keep us posted.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

drakeschmiet1
I tried another account, it worked without any problems.
My sonos system is updated to the latest version

Novy

Hey @drakeschmiet1,
 

Thank you for keeping us in the loop.
 

If another account works fine on your device, the issue may be directly related to your account.
 

Since we haven't received any similar reports, we'd suggest getting in touch with the folks at Customer Support again so they can take a look at your individual account and assist you further, as this isn't something that we can do from the Community.
 

If anything else comes up, the Community will be here for you.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

daneabernathy

Just wanted to say I, and a few other folks in other threads I have found, am having this EXACT same issue. I do not know how or why it stopped working, but this sucks since Google Podcasts isn’t supported in Sonos, and Google only supports Spotify and google podcasts for podcasts. 

Deleting an account should NEVER be a solution to a problem. If I told my users that, I wouldn’t have a job. Spotify has to have the capability to figure out and repair this issue. 

Vasil

Hey there @daneabernathy and @drakeschmiet1,

 

As @Novy suggested, we'd advise getting in touch with the folks at Customer Support again so they can take a look at your individual account and assist you further, as this isn't something that is doable for us in the Community.
Checking your cached data on Spotify's end for errors is something they can do and such errors could very well be causing this kind of issue.
It is worth trying before needing to transfer your entire data to a new account.

Let us know how it goes 🙂
Many thanks!

VasilModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

drakeschmiet1

Hey,

So I reached out to the folks at customer support. After explaining the problem multiple times to multiple people, getting the same "solutions" suggested (new account, clear cache, reinstall the app, etc.) there's still no solution. 

 

They told me that the case was forwarded to a tech team which will contact me via mail. That was more than 5 weeks ago and so I'm sitting here, still waiting for a message from the tech support..... and yes, I checked my spam folder....

 

Novotus

I'm having the same issue. I can play any music from Spotify to Sonos that I want, but I can't play any Spotify podcasts through my Sonos system (from either the Sonos app or Spotify app). 

Kiril

Hey folks,

Thanks for your posts here.

@drakeschmiet1 sorry to hear you didn't receive answer from the Support folks yet, but we'd suggest you to either wait a bit more, or bump your email correspondence there to re-confirm the issue is still unresolved for you. Because when it comes to account related matters, they are the ones that can help you further.

@Novotus could we get more info about your situation as well? Were you able to play podcasts previously and when did you notice this behavior of the app? Have you tried any troubleshooting so far? If yes please share it with us, so we don't give you redundant suggestions. Also, we can suggest to you to try it with a different Spotify account (maybe of a friend or a relative), this is to rule out the possibility of having an account related issue in the first place.

Hope you find this useful. Keep us posted if you have any questions.

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Timeforheroes86

Same issue tried all the listed above. Surely nonsense it "relates to your account". Device maybe. Location?  (UK) again maybe. But a technical glitch like this relative to user ID

 Doesn't ring right at all to me

Suggested posts

Env: prod