Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Problem streaming wirelessly to Roberts Stream 93i

Solved!

Problem streaming wirelessly to Roberts Stream 93i

Shil4207

Hi, I recently purchased a Roberts iStream 93i and ever since have had intermitent problems with being able to stream music via Spotify.

It seems to work occasionally without issue but then for no apparent reason when I try to do so, the display on both the radio, or on the ConnectR app on my phone shows 'Waiting for users'

 

I've tried various solutions - factory resets, making sure my Spotify app is up to date, unplugging the radio etc but this still seems to be an issue. The internet radio is working absolutely fine so I'm confident this is not an issue with my internet connection. I can also connect Spotify from my phone to other devices (Ipad or Ipod) without issue.

 

Any suggestions very welcome because this is very frustrating given that this function was one of the key reasons in choosing the particular radio.

thanks!

Reply

Accepted Solutions
Marked as solution

TonyB212

Just to follow up my own post above, I discovered an interesting workaround that worked for me! The other suggestions on this thread did not work.

 

You'll need a PC or Mac - use that to open Spotify Premium, go to 'devices available' and find the radio. It doesn't have to be switched on at this point. Select the radio, which should change to green text to show the link has been made. Play a track and you should hear it on the radio.

 

Go back to the phone as the track is playing, load the Spotify app and select the radio as a device - this time it should connect. You will also see the PC listed. Try playing a track - it should work, and you should find you can play tracks from the phone from now on. 

 

In my case, for some reason the PC was needed to connect to the radio first and then the phone worked. I'll report back here if it goes wrong again.

View solution in original post

Marked as solution

woodyzelig

Thanks Tony. That solution worked for me too.

View solution in original post

23 Replies

leeroy
I'm having exact same problem. Internet radio is working fine Spotify app on android phone also working fine. Only thing that seems to work is doing a factory reset. Is very annoying & all saved presets are lost having to do this. This is clearly a problem with this model of radio & like yourself the spotify connect feature was my main reason for purchasing this radio on the first place.

Peter__
Do you guys have Spotify Premium which is required to use Spotify Connect?

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

Shil4207

Hi, yes I have Spotify premium.

Interesting, I actually haven't had any issues with the Spotify connection for the last week or so (since I posted the problem). It seems that the Spotify Control tool works fine so long as my internet connection is not interupted (so far anyway!!)

As already posted, if this happens, then the only way to get Spotify Control working again seems to be by doing a Factory reset - even though all of the functions work fine.

 

 

Shil4207

Good to hear it's not just me - very frustrating! Actually, touch wood I haven't had any issues for the last week or so - it only seems to be a problem if you lose, or turn off your internet connection for any reason (mine is left on, but I had previously been experiencing some issues so the connection did get turned off a few times).

One tip though, for when you do have to do a factory reset - if you save all of your Internet Radio presets as favourites too, the radio seems to remember those (even though it loses your presets). At least when you then have to do a factory reset, it means you don't have to find all of your stations again.

Hi I recently bought Roberts 93i Stream and I cannot connect through Spotify Connect. Are there any solutions to this problem? I have to do a factory reset every time for it work and this is very frustrating!!!

Shil4207
I've learned to live with mine....it works fine as long as you leave the
network connection on permanently in the settings. If my broadband
connection is lost though, then it does need a factory reset to get Spotify
working again.

adotw

I am sorry but I have to revive this topic because it's infuriating ...

 

I have the same problem as described by the previous posters and it would be really nice if we could get a technical answer on this matter.

 

The User ID of the account is 1154955536 and I would really appreciate some help regarding this topic.

 

Thank you very much.

tonyrcwade

I'm having the same issues as the above thread.

It's a real PO. If I move the radio to another room, it doesn't work without a factory reset as well.

This is a design fault which needs a software patch or something.

Luckily I haven't got many stations preset as yet and mostly use the Stream93i for Spotify.

richardjohn

It seems like my Mum is having this problem too... she's just phoned me complaining that Spotify is no longer working on her radio.

 

She's not at all technically knowledgeable, and I live hundreds of miles away so this is a complete nightmare. I can't ask her to factory reset as she won't be able to connect the radio to the Internet again.

 

Horrendous that a £160 product has such a huge flaw.

Brian30
Did anybody contact Roberts technical support

Shil4207
Yes, way back when I initially had the problem but got no useful advice
other than everything already tried.

##- Please type your reply above this line -#

whchfue

I have the same issue with Revival iStream 2. Managed to reconnect yesterday without a reset but sorry I do not know why it finally worked. I logged off and in to my spotify account. This morning I have the same problem again. Use it with the main.

when I type in the IP Address in the browser it says spotify status "Logged in" and last error "wrong_password". Display on iStream2 shows the pause icon.

Hope there will soon be a solution.

 

tonyrcwade

I'm still getting the same problems. Reset seems to be the only answer.

I wish Roberts tech support would come onto this forum.

tonyrcwade

I sent Roberts tech support the link to this forum.

Let's hope they respond.

polos_1974

HELLO, i have a radio sangean 28c and have the same problem you describe. When there is a power wifi, it remains suspended and must return to restore the factory settings. I´ve tried everything, but can not find the solution. As you can see, it is not a problem only roberts 93i stream. I hope if you find some solution write it here. Tambine in sangean sesnt a message to Europe to see if they have respusta. THANKS.

TonyB212

I bought a 93i yesterday. Great radio but sadly Spotify Connect will not work with my Samsung S6 phone. I tried rebooting the phone, uninstalling and reinstalling the app, and factory resetting the radio. Nothing works. All I get is 'Waiting for User' in the radio's display.

 

I'm surprised by Roberts - having Spotify built in was one of the radio's selling points, so I'd have thought they'd prioritise a fix. I'm not too bothered as I bought the radio for other reasons, it's still annoying though.

 

Is this just an issue with Android and the 93i, or does it also happen with iOS? 

Marked as solution

TonyB212

Just to follow up my own post above, I discovered an interesting workaround that worked for me! The other suggestions on this thread did not work.

 

You'll need a PC or Mac - use that to open Spotify Premium, go to 'devices available' and find the radio. It doesn't have to be switched on at this point. Select the radio, which should change to green text to show the link has been made. Play a track and you should hear it on the radio.

 

Go back to the phone as the track is playing, load the Spotify app and select the radio as a device - this time it should connect. You will also see the PC listed. Try playing a track - it should work, and you should find you can play tracks from the phone from now on. 

 

In my case, for some reason the PC was needed to connect to the radio first and then the phone worked. I'll report back here if it goes wrong again.

acapulco1950

I've just bought a 93i and Spotify it was working perfectly until I used the ConnectR App on my mobile to control the radio.

 

Then I was only able to connect to Spotify using the Aux input linking the radio directly to the PC. The Radio option appeared in the 

Spotify list of available devices but was not selectable. Tried the Factory re-set etc and eventually fixed it....but not sure how

 

Anyway I've discovered that "ConnectR" has now been superceded by the "Undok" app so will be using that in future and keeping my fingers crossed 

 

 

BLT69

That worked for me too, thanks! That is, the response from Tony B212. I had to factory reset the radio first, but after linking to the radio from my Mac, everything was fine. Still think Roberts need to sort it tho, I don't want to keep losing my presents with the reset.

 

Suggested posts