Help Wizard

Step 1


Samsung Smart TV


Samsung Smart TV



I have a Samsung Smart TV purchased in Dubai, i reset the TV and started it all up whilst connected to my UK VPN, i have the Spotify app but i get a message saying that the TV's firmware doesnt support the app.


Any ideas?


Accepted Solutions
Marked as solution

Hello everyone.

Just been informed that Spotify should be back up for E5000 / 6000 devices now. Ensure your Firmware is up to date and it should be in your Samsung app marketplace.
Airhorn Enthusiast

View solution in original post

89 Replies

Hi there,

Welcome to the Community! Have you tried a firmware update at all?

Check out how we're doing over @SpotifyStatus

Question answered? Just click 'Accept as solution' to help other users out. Easy.

Who's your Spotify Star?

Hi, can you give an indication of when the spotify app will be available for the 2011 D series models.   


Many Thanks

The Spotify app will only work on the 2012 E 7-9 series, the Samsung support told me the other day. True?

I bought a new Samsung 2012 9-series smart tv and was able to use Spotify for few days.

Yesterday when I tried to start spotify, I got a message saying that the TV's firmware doesnt support the app.

I tried to update the firmware, but no new firmware was available for download.

Whoooot wooooot, can someone help with this issue?


EDIT: ( I'm located in Finland)

Same thing 4 me 2day after finally been able to get/download the app "Firmware does not support...". But there is an antidote for that prob, but don't remeber what it was.

Weird...suddenly Spotify started to work again 😄



I've got the same problem! How do I update The firmware on My samsung smart tv?

Please help me!

I bought a SAMSUNG UE40ES5500 a few weeks ago and was really excited to hear the there was going to be a Spotify app released for the Smart TV range. Downloaded and installed the app today. It said I needed a firmware upgrade. Downloaded and installed a new software update. Same error. Very disappointing.


Same problem here. It looks like the app isn't quite ready yet. spotify app (v. 1.003) will not launch on my new samsung tv (UE37ES5500).  A message is returned saying a firmware update is required.  I am on the latest samsung  firmware (v. 001028

The 1029 firmware is out but it doesn't make any difference to update. I did via a USB-stick, but still the same prob! 😞

Same here. Samsung UE ES5800 with latest 1029 firmware (upgraded via USB Stick). Spotify still wants a "newer" firmware 😞

Just got this from spotify customer support:
"We don't currently support the 5500, but with the success of Spotify on other models, it shouldn't be too long before we expand our support to other models, including the 5500. Please be patient. :)"
I think samsung smart hub could be a lot smarter- ie actually say in the app info which devices and os are supported...

I guess that the E 7,8 & 9 series is their primary objective At least from the get.go, and more models later on.

I have a UE40ES6710 and the same experience: Got New firmware 29.0 and still no spotifyapp running on the system. SmartHub reset was not succesful.

Any news from other users? 

I have a series 7 tv recently bought with the latest firmware and still the same error.

TV Model: UE55ES6565

Firmware version: 001028

Year: 2012

Location: Sweden

Spotify App version: 1.003

Error: the device firmware does not support this application please update to the latest firmware



How to check the tv firmware version? Press menu > Support > Software Update > Stay on any of the options but don't press the button, the version appears at the end of the message on the right panel


How to check Spotify version? select the Spotify app but don't run it. Press Tools button on the remote and choose "Information" from the appearing menu.

I bought the UE40ES5500 today and found out that i also got the error message, very dissapointed....

And now there's no internet connection on the Smart Hub! Hopefully they're working on this isue.

I have Samsung UE46ES6715 and I have update the latest firmware, but it still say that the device is not supported...





Suggested posts