Spotify App on SB Touch and Radio has no sound for most tracks

Reply

Spotify App on SB Touch and Radio has no sound for most tracks

codonagitat
Regular

It seems that Logitech is not able to fix this or is waiting for spotify to fix this. I am one of those new german customers and are having the same problem. Which ruins Spotify Premium to me.

 

 

Many tracks/albums play flawlessly, but there is a large number of albums that don't seem to play at all. The interface shows them playing with the track time counting down but there's no sound! It's 100% consistent with certain tracks. For example, I can play "Jolene" by Dolly Parton and it works 100% of the time. But if I try to play "Seven Nation Army - Live" by The White Stripes there's never any sound. When I find a track with no sound, every other track on that album has no sound as well.

They all do play on my Android Smartphone and Notebook. This is not a region problem.

 

 

http://forums.logitech.com/t5/Squeezebox-Players/Spotify-App-on-Touch-has-no-sound-for-most-tracks/t...

 

and http://bugs.slimdevices.com/show_bug.cgi?id=17910

4 Replies

David
Spotify Legend
The Seven Nation Army track might be a "linked" track, which causes some issues with the Logitech system.

If, for any reason, a track on an album or playlist becomes unavailable Spotify will attempt to find an identical copy of the recording from another source in the catalogue. Where this has happened, you will still be able to play the track, and you will see a link / chain icon to the right of track when viewing in a Spotify desktop client.

Unfortunately, the Squeezebox Spotify app does not perform this "re-linking". The development teams at both Logitech and Spotify are aware of this issue and will be working for a solution.

It is possible to work around this, by manually replacing each track in playlists with the specific "source" track (found by clicking the link icon). However, this can be quite labour intensive, so it is not a permanent solution.
Airhorn Enthusiast

codonagitat
Regular

Thanks you for the quick reply. A check on my SB Touch and Radio shows that these following two tracks are not playing. Accually none of the almbum tracks:

http://open.spotify.com/track/1Jk5chO7uosvko9LjYORJx

or something totally different

http://open.spotify.com/album/4to18PfZNzoo3BjkkLWQXT

 

They seem not to be linked. They do play on my Notebook and Android. 

The problem might be something other?

codonagitat
Regular

Did some more research. You are right! These files are linked.

I do not see the link icon on the desktop client nor on my android smartphone. But i installed the iphone version on my ipad and the ios Client shows those link icons.

 

David
Spotify Legend
The way these versions of Spotify were built up means it's harder for them to locate those linked tracks - By locating the track it's being linked to and then moving that into the playlist should get these tracks to play once again. Let me know how you get on.
Airhorn Enthusiast
SUGGESTED POSTS