Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify Connect devices available remotely

Spotify Connect devices available remotely

I've got a pair of NOCS NS2 speakers, that support Spotify Connect. It works (kind of) good to play music there. What puzzles me is, that I always see those speakers as available remote devices, even if I'm not on the same Wifi (e.g. not at home, at another location, another country, another continent). To me that is a) inconvenient and b) dangerous.


a) I often have multiple speakers in that list and only want to see those that are available and close by. Why would I select speakers on the other side of the globe?

b) If I select those speakers by accident and pull up the volume, my neighbors probably won't be delighted and I won't notice, as I'm not close by. Even if I let anybody else access my wifi, they can afterwards play music to my Spotify Connect speakers, even if they're not around. Not funny!


So please, disable playback to speakers that are not on the same network!



3 Replies

Agree! HUGE problem- someone was playing music to my speakers and they were not anywhere near me. How long has this been a feature??

Hey there @Dsg76


Thanks for reaching out about this in the Community. 


We'd first recommend going to Settings > Devices > Show local devices only. This option should be toggled on. 


Let us know if you notice anything new after this. 


We'll be on the lookout.

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!


On which app should make those changes?  My nephews?   He is the one that is able to play music remotely.  

Suggested posts