Help Wizard

Step 1


Spotify jutters and skips playing through bluesound node 2

Spotify jutters and skips playing through bluesound node 2

My new bluesound node 2 plays everything well except Spotify which jutters and skips all the time.  I have checked and rechecked network, have tried all suggestions available from spotify and bluesound support and same result.  Only further suggestion from bluesound is to “reset account” with spotify.  Can spotify do that and will it help?  Will it cause loss of my music collection?

5 Replies

Hey @rfs45, help's here.


This doesn't have to do with your account, so let's try some troubleshooting. First, restart all your devices (and speaker/receivers). Also, make sure that:

  • All devices are on the same WiFi network.
  • Your Spotify app is up-to-date.
  • All devices’ software is up-to-date. If you don't know, check with your devices' manufacturers for how to update the version software.
  • If possible, try switching between different networks and see if that helps.

Let us know how it goes 🙂


I am having the same problem. It started about 2 months ago.

Bluesound has tried to find the problem, but they say it is Spotify. Since Spotify won't allow them to access their API, they have no ability to rectify the matter.

And, since Spotify doesn't have direct customer service, this issue will only be corrected if enough people have the same problem.

The good news:

Quobuz and Primphonic will be added to Bluesound soon, so maybe this is a good thing. Spotify doesn't want to offer hi resolution, and Spotify doesn't want to offer direct customer service. So Spotify will go gently into that night like Sirius/XM.

Buh Bye...

Same problem with Node 2i. Did all troubleshooting, and contacted BluOS support. They say it's Spotify problem. All other services works fine, Spotify keeps pausing randomly.

Very disappointing! 😞

Can you scale the resolution of the problem?

Recently I bought powernode 2i and unfortunately experiencing same problems. I replaced my router (was pretty old one), assigned static IP address powernode and turned on UpNp in the router. All this is not helping. I'm in contact with the retailer and BLUESOUND support desk. Will keep you all posted.

I soved my probem. I turned on auto sense for one of the optical inputs. My bit older television is connected via COAX/optical converter to this inut. When television was of, this was causing troubles with auto sense activated. Now I turned off auto sense all my problems are solved.

Suggested posts