Announcements

Help Wizard

Step 1

NEXT STEP

Spotify link does not autoplay in desktop app (Windows)

Solved!

Spotify link does not autoplay in desktop app (Windows)

Any idea on how to bypass the web player when attempting to open links? When I click on a link such as https://open.spotify.com/track/7rbCL7W893Zonbfnevku5s, it used to open in the desktop app.

 

After an update (no idea when exactly it began), it started to open in the web player. I have to click 'play on spotify' in order to get it to play in the application. I've checked all the necessary boxes, both on the web player settings to allow playing in the desktop app and on the desktop app to allow opening the app through the web.

 

I get this page when I click on the song link, no autoplay despite correct settings:

 

Capture8.JPG

 

Any ideas?

Reply

Accepted Solutions
Marked as solution

Hey @prancingrobot,


I've checked with the staff and this happens to be expected behaviour.

Thank you for your feedback, we've passed your thoughts to the developers : )

View solution in original post

10 Replies

Hey @prancingrobot,

 

Welcome to Spotify Community!

Can you confirm if "Play open.spotify.com URLs in desktop app" button is checked in the webplayer settings?

 

Screen Shot 2016-04-30 at 21.21.54.png

hey @Dreadlord, yup the setting is checked:

Capture22.JPG

Hey @prancingrobot,

 

Alright, can you check if this option is enabled in your Desktop client?

Screen Shot 2016-04-30 at 21.54.01.png

@Dreadlord yup, it's turned on:Capture12.JPG

Hey @prancingrobot,

 

It doesn't work for me as well for some reason.

Can you pass me the following information so I check with the staff:


1. Your device.
2. Your device's operating system.
3. The exact Spotify version installed (check About Spotify)

Thank you!

Hey @Dreadlord, I'm on a Lenovo T440s running Windows 10 and version 1.0.28.87.g8f9312a4

Hey @prancingrobot,

 

I have escalated this to the staff for you, we will get back to you soon with any update on this. 🙂

Marked as solution

Hey @prancingrobot,


I've checked with the staff and this happens to be expected behaviour.

Thank you for your feedback, we've passed your thoughts to the developers : )

@prancingrobot I've submitted an idea to get this feature back.

You can support it by adding your kudos here.

Cheers, thanks for the help!

Suggested posts