Announcements

Spotify on Music Cast controlled via Alexa - This is not working

Spotify on Music Cast controlled via Alexa - This is not working

Delta777

Plan

Premium

Country

Sweden, but I have tried to trick the system by using the address to Spotify's office in New York, USA

 

My Question or Issue

 I can't get Alexa to play Spotify on my Yamaha Music Cast system.

I have tried the suggestions offered in other posts here, but nothing works. Actually, Alexa does not even play Spotify on the buil in speaker in my Echo Dot. I even set all my locations in every app and relevant web service to the address on Spotify's office in New York. So guys, things I order on-line will from now on be shipped to you in NY. You just have to solve it.

 

Also, the Swedish website for Spotify pretends that Alexa talks Swedish... That is fake. She does not understand Swedish, so you better change that false marketing info on your web asap.

 

I can read "Spotify" as an option in the Alexa app, but it is disabled and can't be turned on. Is it because my luxury Familly Premium subscription is registered as a free ad-supported profile? I have asked Amazon customer service about this a couple of times the past weeks, but guess what - there is never a reply. What a non-surprise. So I hope someone at Spotify can assist instead. Thanks!

Reply
3 Replies

Guido

Hey @Delta777.

 

Thanks for getting in touch!

 

Seeing that Amazon Alexa and (of course) Spotify are supported in Sweden, there is no need to use different country settings. This could actually complicate things so we recommend to reset your devices to their original settings.

 

You mention that you are using Premium for Family and Free. If you'd like to use Spotify on your Amazon Alexa, you need a Premium account. So try to add your Premium account in the Alexa app. you can do this as follows:

 

  1. Select Settings, then Music & Media.
  2. Select Spotify, then Link account to Alexa.
  3. Enter your Spotify Premium account details.
  4. Ask Alexa to play something ("Alexa, play Discover Weekly").

Should do the trick! Let us know if it doesn't or if you have further questions.

 

Have a nice day.

Delta777

Thanks for trying to help with Alexa. I have aligned all settings everywhere to my actual address in Stockholm, Sweden. No change, Alexa does still not accept Spotify.

 

I have a Premium Family sub. Spotify is visible but disabled in the app. I don't get the question to link my Premium account.

 

Any more ideas?

 

Best Regards Tomas

 

Peter

Hey @Delta777.

 

Thanks for getting back to us, and apologies for the wait!

Could you send us a screenshot of the disabled Spotify option so we can get a better idea of what the issue might be?

 

In the meantime, would you mind trying to connect to your Echo Dot through another device, first using your Family member account, and then if possible trying with the Family owner account? 

 

Let us know how it goes!

Suggested posts

Env: prod