Announcements

Spotify web player loads but cannot play music behind corporate firewall

Spotify web player loads but cannot play music behind corporate firewall

Hi guys,

 

I'm behind a corporate firewall/proxy and I can load https://open.spotify.com but no music plays.

 

Here are the console log errors:

 

-----------------------------------

web-player.ac4113d7.js:1 WebSocket connection to 'wss://lon-dealer.spotify.com/?access_token=...' failed: Error during WebSocket handshake: 'Upgrade' header is missing
r.authenticate @ web-player.ac4113d7.js:1
r._authenticateWithToken @ web-player.ac4113d7.js:1

 

VM392 container.html?n=1:13 GET https://ib.adnxs.com/ttj?id=11554360&size=728x90&cb=1133258866&age=31&gender=male&playlist=&genre= net::ERR_SSL_PROTOCOL_ERROR

 

GET https://t.myvisualiq.net/sync?prid=BUKIPNR1&red=https://tags.bluekai.com/site/21398?id=$%7BUUID%7D 403 (URLBlocked)

------------------------

 

I tried https://play.spotify.com/?http=1 but it didn't help.

 

Other streaming sites work. Any ideas how to fix that?

 

Thanks!

Reply
5 Replies

Same problem here, can we get some help please?

Is there a way to correct this issue? Apparently the issue is due to corporate proxies blocking advert requests. Nevertheless, I am a subscription user, so I should be able to stream my music at will. Or at least play the offline versions. This seems like a recurrent issue that spotify is not dealing correctly.

The https://play.spotify.com/?http=1 url had worked for some time, but then it started redirecting to https://open.spotify.com/browse/featured?http=1 and it all stopped working.

I can browse every music, playlist, etc. but when playing, the traks keep skipping to the next. This is super annoying and making spotify irrelevant for a big chunk of my day, while I'm working.

I've got the exact same issue.

Funnily enough my co-workers use mostly Amazon Music, which works fine.

Apperently our corporate firewall seems to block websockets and spotify uses that technology while Amazon Music doesn't.

It would really help to get an alternative html5 player or something.

2018 and it is still not working. I used Deezer at office for years before switching to Spotify and I am unsubscribing without any doubt if they do not address this issue. 

hi guys

 

now I have exactly the same problem like the other guys descibed. 

is there any solution for this?

Suggested posts