Spotify won't play on my new Amazon Echo

Reply

Spotify won't play on my new Amazon Echo

MrNRave
Visitor

Plan

Premium

Country

UK

Device

Samsung Galaxy S7/Amazon Echo

 

My Question or Issue

We bought one of the new Amazon Echos on Black Friday so we could listen to music with it. I connected my free Spotify account to it and it seemed to work. I have since paid for a premium Spotify account but the Echo will no longer play music from my Spotify. The Echo also doesn't show up as a device in my Spotify app on my phone. When I ask it to play music it will say it's going to play something from Spotify but then nothing happens.

 

I have tried all the steps I can find such as un-linking and re-linking the app multiple times and also uninstalling the Spotify app from my phone then re-installing it again but nothing has worked. Can anyone help? I specifically bought the Echo so I could listen to my Spotify through it.

4 Replies

Ohnonotyou
Casual Listener
Silly question, but did you log out of your Spotify account at any point? I had a problem getting Alexa to play my playlists which was fixed simply by logging out of Spotify, then logging back in.
Also, note that you link Alexa to Spotify via Settings->Alexa preferences->Music & podcasts (in the Alexa app), not via the add devices procedure.

Ohnonotyou
Casual Listener
Perhaps I should also mention that I run Spotify via the desktop app on a PC, not via a phone app. If you have both apps, it is conceivable that you might need to log out of Spotify on both of them.
When I linked Alexa to Spotify, my Echo appeared as a device in Spotify without my having to change anything in the Spotify app.

Peter
Spotify Legend

Hi there @MrNRave,

 

Thanks for posting about this and welcome to the Community 🙂

 

You can give the steps @Ohnonotyou mentioned a try.

 

If the issue persists, try the following:

 

1. Unlink your Spotify and Alexa accounts. Find how here.

2. Turn your Echo speaker off.

3. Restart your router by unplugging it from power for at least 15 seconds.

4. Log out from your Spotify account, restart your phone, and log back in.

5. Turn on your Echo speaker and link your accounts again.

 

Also, make sure you're running the latest version of the apps. You can check that in the Play Store.

 

Keep us posted on how it goes.

headlam65
Casual Listener

I've had the same issue but got my Amazon Echo to work by changing my Swedish address to a UK address 3 years ago. I brought my Alexa in the uk. I kinda understood why this was an issue at the time considering that Amazon wasn't in Sweden but I don't undetstand why this would be an issue now 2020? Why does one get the 'You are not eligible to enable this skill due to geographical restrictions' in the first place? Why are their restrictions on a product sold around the globe?

I gave up on my Firestick in 2017 when I couldn't use Youtube app when Amazon and Youtube were at war but why is this a issue today? I can use my Amazon Echo via bluetooth but it's a lot better when I can talk to Alexa directly. Chaning the address to a uk is a pain now as Amazon are in Sweden and I use my account for shopping in Sweden.

SUGGESTED POSTS