Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Thumbnails doesn't match the episode on app

Thumbnails doesn't match the episode on app

Hi there,

 

I'm hosting a podcast (at Buzzsprout) and are experiencing troubles showing the right thumbnails in the podcast-feed in Spotify. My RSS-feed looks fine and is correctly linked between each thumbnail and episode, and on desktop and in some devices it's not a problem. But on my husband's and my iPhone as an example, Spotify keeps mixing the thumbnails so that they don't match the specific episodes. The episodes are with different guests, and the podcast is in it's beginning, so it's pretty critical that potential new listeners / followers meets the correct feed. 

 

Hope it makes sence 🙂 

 

Has anyone else experienced the same? 

Reply
8 Replies

I'm having the exact same issue. On the Spotify podcasters website the thumbnails have been uploaded fine, but on the Spotify app the thumbnails keep getting jumbled / mismatching the episodes

Hey folks, 

 

Welcome to the Community! 

 

If this is happening on multiple devices, it's best to reach out to our colleagues from the Podcast team here. They can take a look and assist in the best way 🙂

 

Cheers and we're here if there's anything else.

IvelinaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Hey there, I wanted to clarify that this issue is prevalent for every podcast I interact with as well, so it’s not specific to the OP’s podcast only. This includes episodes from global top 10 podcasts.

 

Please see a screenshot example of the issue, noting that it’s from February 2024. It’s July 2024 and the issue still persists.

 

Short of asking each podcast owner to report to the Podcasts team, is there another update? And/or a bug fix link we can follow and “+1” besides this thread?

IMG_1825.png

Hey @psullivan6,

 

Thanks for reaching out!

 

I tried replicating and the episodes you shared have the correct thumbnail on my end, so could you you confirm if this is happening only on your phone or on all devices you use? If possible, you can also check with someone else how it looks like on their end and ask them to log in to their account on your device to see if there's a difference.

 

Let us know how it goes.

 

Take care

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

It's happening on my iphone as well. The podcast I am looking at is Family Proclamations, and the thumbnails go all willy nilly when I play an episode, although the cover art is correct on the playing episode itself. 

I'm getting reports from friends that they are seeing the same thing. Episode thumbnails are mixed up, but when you play an episode the correct cover art is displayed. 

Hi folks,

 

Thanks for the replies. 

 

We've been looking into this and here's what we've been able to gather. Follow the steps below that best apply to you:

  • If you publish your own podcast and are facing issues updating the thumbnails, be advised that these can take 24 hours to update. See here for more info.
  • If you (as a user) are facing issues where the image is inconsistent between the queue, the Now Playing view and others, this is most likely a caching issue. Perform a clean reinstall on your device, this should help resolve this
  • If the image is wrong everywhere you look, across multiple devices and regardless of who looks at it, this is most likely an issue with the podcast itself. You can report this to Spotify here or reach out to the creators

Hope these help you out.

JoanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi Joan! I did a fresh install and it didn't resolve the issue. I am seeing this happen on several different podcasts, not just mine, so I don't believe it is an issue with localized devices. I think it's an error with the app itself. 

Suggested posts