Volume control of Drumfire speaker via Connect is buggy

Solved!
Reply

Volume control of Drumfire speaker via Connect is buggy

Iszmatic
Casual Listener

Plan

Premium

 

Device

Speaker: Audio Pro Drumfire

 

Operating System

Android phones with both Oreo and Pie, Windows 10 Desktop with the Spotify app, also tested via open.spotify.com in Chrome and Firefox. 

 

My Question or Issue

 

When selecting my Drumfire unit as the listening device in Spotify, I can not initially control the volume via Spotify. The Spotify client shows the volume going up or down but the Drumfire plays at the same volume regardless. If I, however, change back to playing the music in the client on my phone or desktop and then select the Drumfire a second time, the speaker reacts properly to volume changes in the Spotify client.

 

I have opened a support ticket with Audio Pro but as of yet they have not been able to solve the problem stating that it is completely unknown to them why this would happen. I have gone through factory resets of the speaker, WiFi router, fresh installs of Spotify on both phones and desktop but the issue remains 

 

I took a video demonstrating the issue (the speaker is named "Vardagsrum") but its too large to attach (35mb) so here's a streamable version:

 

https://streamable.com/64dyu

1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Jemi
Spotify Legend

Hey @Iszmatic, help's arrived. 

 

That sounds odd, and even though we can't determine where the issue lies yet, it does sound like the speaker isn't connecting properly since you've tried connecting from several different devices and reinstalled the app. 

 

Do you have other speakers you can try connecting to? Just to see if the same thing happens. 

 

Also, have you made sure you have the latest firmware installed on the speaker? 

 

Lastly, can you try logging in and connecting to the speaker with another account, such as a friend's?

 

Keep us posted 🙂

View solution in original post

2 Replies
Solution!

Jemi
Spotify Legend

Hey @Iszmatic, help's arrived. 

 

That sounds odd, and even though we can't determine where the issue lies yet, it does sound like the speaker isn't connecting properly since you've tried connecting from several different devices and reinstalled the app. 

 

Do you have other speakers you can try connecting to? Just to see if the same thing happens. 

 

Also, have you made sure you have the latest firmware installed on the speaker? 

 

Lastly, can you try logging in and connecting to the speaker with another account, such as a friend's?

 

Keep us posted 🙂

View solution in original post

Iszmatic
Casual Listener

I can't believe neither me nor Audio Pro thought of checking if the speaker had the latest firmware. I even factory reset it and still didn't think of it.

 

After a firmware update the volume control is now working flawlessly! Thanks! 

SUGGESTED POSTS