[WP8] Serious bugs in the new update

Solved!
Reply

[WP8] Serious bugs in the new update

stndr
Regular

Hi!

 

The newest Spotify update is horrible. I have Lumia 620 and since the update Spotify WP8 app is now useless. The Spotify app doesn't work at all if the screen is locked. Music stops after the app has played the track which was chosen. Only one song of a playlist is played. When I unlock the screen the app will start to play the same song all over from the start.  This doesn't happen if I keep the app "open" and don't let the screen go blank. I have tried to reinstall Spotify but it did not help.

 

- Finland

- Nokia Lumia 620
- Version 2.0 (0.6.4.113.gf895e1a1)
- Problems in Wifi and 3G

2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

MichaelJerzak
Composer

@stndr wrote:

Some strange new information...

 

The app works fine with the shuffle on. Without it there are the mentioned problems.


very strange indeed.

View solution in original post

Solution!

TheeJC
Casual Listener

I have the same issue, but I have found a workaround:

 

1. Start the playlist you want to hear.

2. Hit the back button until you completely exit the app (eg, kill it)

 

That's it.  Now not only does this bug not repro, but it significantly reduces the lag when skipping songs use the system audio controls (when app is not in foreground).  This is a pretty huge issue for me and it appears to get worse when there is some, but poor, cell reception.  Do you guys test low connectivity / poor signal?

View solution in original post

19 Replies

MichaelJerzak
Composer

@stndr wrote:

Hi!

 

The newest Spotify update is horrible. I have Lumia 620 and since the update Spotify WP8 app is now useless. The Spotify app doesn't work at all if the screen is locked. Music stops after the app has played the track which was chosen. Only one song of a playlist is played. When I unlock the screen the app will start to play the same song all over from the start.  This doesn't happen if I keep the app "open" and don't let the screen go blank. I have tried to reinstall Spotify but it did not help.

 

- Finland

- Nokia Lumia 620
- Version 2.0 (0.6.4.113.gf895e1a1)
- Problems in Wifi and 3G


have you tried rebooting the device?

stndr
Regular

Hi!

 

Thanks for the reply 555michael. Yes, I have tried rebooting too. Still have the same problem.

MichaelJerzak
Composer

@stndr wrote:

Hi!

 

Thanks for the reply 555michael. Yes, I have tried rebooting too. Still have the same problem.


have you tried filling out a Customer Support Contact form found here: https://www.spotify.com/us/about-us/contact/contact-spotify-support/?contact

stndr
Regular

Some strange new information...

 

The app works fine with the shuffle on. Without it there are the mentioned problems.

Solution!

MichaelJerzak
Composer

@stndr wrote:

Some strange new information...

 

The app works fine with the shuffle on. Without it there are the mentioned problems.


very strange indeed.

View solution in original post

stndr
Regular

...and suddendly after taking couple of times shuflle on and off  it started to work. Don't know what was the problem but I had it for few days. Thanks 555Michael for the help. Sometimes these technical issues get quite mystic.

MichaelJerzak
Composer

no problem 🙂

The-Antipop
Regular

I have exactly the same problem with my Lumia 920 as user stndr. Shuffle on/off did help for a while today at work but it seemed to work randomly. At the end of the day turning shuffle on/off did not help at all. I really hope Spotify devs will notice this and check why this happens. I have re-installed Spotify app, tried on 3G and WiFi, logged in and out and it haven't worked.

 

Information:

- Finland

- Nokia Lumia 920

- OS: 8.0.10211.204 FW:1232.5957.1308.0001

- Spotify WP8 version 2.0.4933.0 (core 0.6.4.113.gf895e1a1)

- Using mostly 3G, sometimes WiFi

stndr
Regular

Yep, I have the problem back again... Could it be that it has something to do with Finnish language package... With the last version I had a problem with having too many playlists. Don't know would it help to delete some playlists again... Hope someone does something.:)

stndr
Regular

Hi The-Antipop!

 

I think I solved the problem by deleting loads of playlists. Seems that Spotify WP8 can't handle too many playlists. I suggest you to try the same.

The-Antipop
Regular

Hey! I started deleting my playlists and noticed that in some playlists Spotify App didn't show how many tracks I got in the playlist. I scrolled down to the end of my playlists and suddenly it updated the count of tracks in all the playlists. (including ones inside playlist folders) After that I tried playing a song without shuffle and locked the screen and it started playing the next track! I've now tried playing songs from albums and playlists and it's working for now! Maybe the answer is that all the playlists must be updated to show correct amount of tracks. 

 

If this suddenly stops working, I'll delete most of my playlists for sure to test that out. Thanks!

BlackswanJon
Casual Listener

Deleting playlists seems to miss the point when you're paying good money to have playlists - I have never yet managed to get this so called app to play anything from any of my playlists, neither in beta nor v2 - not a peep.

Anyone managed to resolve from there please?

 

Solution!

TheeJC
Casual Listener

I have the same issue, but I have found a workaround:

 

1. Start the playlist you want to hear.

2. Hit the back button until you completely exit the app (eg, kill it)

 

That's it.  Now not only does this bug not repro, but it significantly reduces the lag when skipping songs use the system audio controls (when app is not in foreground).  This is a pretty huge issue for me and it appears to get worse when there is some, but poor, cell reception.  Do you guys test low connectivity / poor signal?

View solution in original post

The-Antipop
Regular

Hey TheeJC!

 

First I have to say that I love you because this have made my day at work so much easier! I have tested your workaround for 2 days 8 hours per day now and it have always worked! It doesn't matter if I am listening albums or playlists shuffle on or not. Thank you! My 3g-connection is already so slow that yes I am using low connectivity. At my work there are places where 3g does not even work. 

 

and BlackswanJon, do you see any songs in your playlists? First time I installed this update it showed nothing in my playlists. I just re-installed it and tried again. Then I noticed it was updating the amount of songs in my playlists but it was really slow with it so I just waited for all of them to update.

TheeJC
Casual Listener

Glad it helped, and also to hear that you have the same experience that I do.  If nothing else it proves that this is a completely fixable issue and Spotify can take care of it in a future build.  Fingers crossed that the next update doesn't take as long as the current one did (and breaks less stuff).

BlackswanJon
Casual Listener

Thanks to The-AntiPop for asking: so far the app is behaving but I haven't yet added any new playlists and so not reached the original number of items to really test it. Will update when I've dragged a few in.

user-removed
Not applicable
Hey there.

I was in good boat this week. What smartphone for Spotify need. Readed all these complaints about new update of Spotify for Windows Phone and after hour I was at home with new smartphone with Android. 🙂

SpotyFly
Casual Listener

I have a HTC 8S, with the original Spotify version I had the problem of the App crashing when I scrolled through the playlists.  With the new version - it's even worse, still crashes when scrolling through the playlists but in addition to that when playing a track every few seconds there will be what I descibe as a 'micro pause'.  After 2 or 3 of these 'micro pauses'  the playback then becomes all distorted.  To get rid of the distortion I have to pause the playback and then re-play, but it will happen again a minute or so later.

 

Too many bugs for me, I have been a great fan of spotify for desktop and was pleased to see the mobile app come out for wp8, but the problems don't seem to get resolved, have cancelled my premium subscription





 

rule
Newbie

I still have the same issue as you described on my Nokia Lumia 920. I will try the work-arounds described in this thread, hopefully that will help.

SUGGESTED POSTS