Web Player can't load on firefox or Chrome

Reply

Web Player can't load on firefox or Chrome

Velex
Regular

macbook pro 2109, running mojave os.

 

i get a blank page when I try to load the web player. happens on both Chrome and firefox, on private browsers too.

 

 

chrome.png
firefox.png
firefox private browser.png
5 Replies

Mihail
Moderator
Moderator

Hi there @Velex

 

Thanks for reaching out about this in the Community.

 

Would you mind letting us know if you already tried clearing the browser's cache and cookies? Sometimes the cache can lead to different issues. 

 

If that doesn't do the trick - could you try resetting your router or giving it a go using a different network, such as a mobile hotspot? If it works with another network, you should contact your internet provider about possible restrictions that might be active for your connection.

 

On another note - are you able to use the Spotify app on your MacBook?

 

Keep us posted. We'll be on the lookout for your reply.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Velex
Regular

I've tried clearing the Cache. Doesn't work.

 

I've tried opening spotify in all sorts of different stable networks (including mobile hotspots), most of which give me blank pages like the second screenshot I sent. The rest give me insanely long loading times.

 

The Spotify App works fine on my macbook.

 

side note: the webplayer appears to work fine on Firefox private windows now, loads incredibly slowly on firefox normal windows, and refuses to load on any chrome tab.

Mihail
Moderator
Moderator

Hey @Velex,

 

Thanks for getting back to us.

 

The results of the troubleshooting you've done indicates that something is interfering with your browsers connectivity to our servers. It's possible that some of the addons you have installed are causing this. It's a good idea to reinstall your Firefox browser and see if the web player functions correctly with no addon activated.

 

Hope this helps. Let us know how you get on.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Velex
Regular

I've removed all addons and reinstalled firefox and chrome. chrome still doesn't work even with no addons installed, while firefox seems to be working even with all my old addons enabled. I'll check again to make sure it holds up.

Alex
Moderator
Moderator

Hi there @Velex,

 

Thanks for the info.

 

Another thing you can try is to remove any entries that contain Spotify From your host files. This can sometimes cause issues with the Web player and Desktop app. Follow the steps described in this Solution.

 

Hope this helps.

 

 

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!
SUGGESTED POSTS