Announcements

link error with Amazon Echo

Solved!

link error with Amazon Echo

Just set up Amazon Echo and upgraded Spotify to Premium.  All running well via Sonos.

However, Amazon and Echo will not link and just says "an error ocurred while attempting to link Alexa with external provider"

Any help happily accepted?

Thanks

Reply
48 Replies

This worked for me: In the Alexa app go to Music, Videos, & Books. Under Music select Spotify. In the header, it was default set to "[Your name]'s Amazon Apps." Tap on this and change it to "[Your name]'s Echo." This will give you the Spotify setup page for the Echo.

When I first logged into Spotify through the Alexa app I used my email address and it wouldnt work. I changed this to my username as shown in the settings on my Spotify app and it worked perfectly. Based in the UK using a premium account.

I also had to connect through the Spotify app. The Alexa app said "app support not available" and I couldn't find a workaround. But when I did what you said and opened Spotify, I connected Alexa that way and now it plays.

Hey I have this same problem and i tried following your instructions however I can’t seem to find Digital content, I am under “Your Account”, please help

After you connect your device(phone or laptop) to spotify just say "Alexa, on spotify!!!" Song ex: "play hotel California by the eagles"

God Bless your soul - and thanks.

This worked ! Thank you soooo much !!!!

Many thanks BigC. I tried a lot of things & time at Amazon end and Spotify app on iPhone unsuccessfully. 

 

Following your tip connecting Alexa Echo Dot from my Spotify premium account on Mac worked! What a relief!

Thanks, My speaker is working now

I love Alexa and Spotify. A lot of fun and music streaming. I am working with SmartHomesMaker in the USA.

Suggested posts