Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

open.spotify.com webplayer stops playing music after 9 seconds

Solved!

open.spotify.com webplayer stops playing music after 9 seconds

Today the new webplayer open.spotify.com was pushed to me again instead of the old (working) play.spotify.com. After selecting some music I pressed play, but every songs just freezes after playing exactly 9 seconds. The music stops, but the player doesn't show anything, it just pretends it keeps playing. I have to refresh the page to be able to play music again, for 9 seconds only. The browser I use to play music is Google Chrome 58.0.3029.41 beta on Windows 7, without any extensions or add-ons.

spotify dead.PNG
Reply

Accepted Solutions
Marked as solution

I found some advice online that said to go to your account, click Sign Out Everywhere, then sign back into the web player. This seems to have resolved the issue for now. 

View solution in original post

21 Replies

I also have this issue at exactly 9 seconds. I am on windows 10 and Chrome 58.0.3029.41 beta just like you.

It doesn't work at all for me in Firefox/Linux 14.04

 

There's just a message at the top saying 'something went wrong'

 

...and yes, thee old play.spotify.com was working fine

Same issue here, exactly 9 seconds.  Windows 10, Google Chrome 58.0.3029.41 beta-m.

 

I'm a Web developer, so I'm going to go into a little more detail here. The new player is clearing using the new media playback APIs so it doesn't rely in Flash anymore in modern browsers.  Most segmented media files use 10-second segments, so I'm guessing that's what we're dealing with—it's loading the first media fragment and then failing to load the next one.

 

It looks like there's a JavaScript error being thrown: "Uncaught (in promise) DOMException: The play() request was interrupted by a new load request." (a._loadProtectedTrack @ web-player.e7aa634f.js:27)

 

I tried testing this in Microsoft Edge, but it looks like that browser is still being directed to use play.spotify.com—but actually fails to work there either because of a completely different error.

 

Seems like the Spotify team needs some better QA processes.

i`m have the same issue here.
Chrome  58.0.3029.41 beta (64-bit)

Thanks for the useful input. 🙂 I am receiving a lot of "net::ERR_INSECURE_RESPONSE" and a "503 (Service unavailable: back-end server is at capacity)" if I check the console when trying to playback music.

It doesn't work with me at all as well. It just says 'something went wrong'. I feel like moving to another service, this issue is going on for too long.

You can switch back to the old web player by changing your browsers user agent string. Chrome has multiple extensions that can do this for you. By changing your user agent to

"Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1866.237 Safari/537.36"

you can load https://play.spotify.com instead of the terrible https://open.spotify.com again without being redirected.

For anybody else on Linux/Firefox I solved this by upgrading to the latest versions.

Desktop player ma ten sam problem.

I have the same problem and am seriously considering dropping Spotify since there doesn't seem to be much attention given to this service issue. Using both Firefox and Chrome, but I don't have control over the versions because it is a work computer. 😕

For me the music plays for a good 30 seconds, and then the audio stops completely but the song keeps going and the only other option I have is to reload the page. 😕

for firefox i solved it by updating to firefox beta

Why is this still an issue? And how did it now start showing up for me when I was fine up until today? No matter what I've done I always get redirected to open.spotify.com.

 

Granted my issue is slightly different. I have this issue only when playing certain songs. All other songs play fine but on specific songs it stops playing audio at the 9sec mark yet continues to look like it is actually playing. One song in particular is "To **bleep**" by Cobra which is a band from Peru.

This is STILL an issue.

Yeah, I'm experiencing the same problem. It occurs at the 9 seconds mark always. I'm using Chrome on 64-bit Ubuntu 16.04 and the browser version is 59.0.3071.86. I'm getting the same error on console as someone else earlier in this thread, it says exactly:

 

web-player.c6f68273.js:29 Uncaught (in promise) DOMException: The play() request was interrupted by a new load request.
a._loadProtectedTrack @ web-player.c6f68273.js
a._loadACMETrack @ web-player.c6f68273.js
 
I upgraded my browser from Chrome 58 to 59 today, and this issue appeared after that.
 
I tested with firefox too, and it seems to be experiencing a similar problem. I'm able to play only the first 7 seconds of every track. But the problem behaves a bit differently. On chrome the playback gets stuck on 9 seconds, but on Firefox the next song in the queue starts playing after 7 seconds. I have attached a screenshot of the errors on console on firefox since there were so many I have no interest in writing them all down by hand. The Firefox version I'm using is 54.0, on Ubuntu 16.04 too.
 
Oh, and with both browsers I disabled all the addons that might block execution of js.
Screenshot from 2017-06-30 23-38-34.png

I'm having the same problem (9 seconds of play, then freezing) using Chrome, albeit only for some, but not all, songs.  Hasn't been a problem until today.  

Same issue here. Stops at 9 seconds on certain songs and does the same thing if I try refreshing the page. Only option is to skip the song. Why hasn't Spotify even replied to this issue???

Marked as solution

I found some advice online that said to go to your account, click Sign Out Everywhere, then sign back into the web player. This seems to have resolved the issue for now. 

I am not impress with their service either. I have complained on mulitple forumns and emails without any sucess.

Suggested posts