Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Address search not working

Address search not working



My Question or Issue

I'm being prompted to add an address to continue using Premium Family.  When taken to the address page, the search feature is not working.  I get a message that it does not recognize my address just a few characters into typing. Even upon full completion of the entry, it still says it doesn't recognize it.  



Worked for me this morning - Chrome on Mac OS, US address.  Whether its fixed for good or not is unclear as the last update I saw was "working on it."  

33 Replies

same with mine 😞 annoying!!

Same! So frustrating


Me too

me too.. wonder if anyone is even checking these problems.


I gave up.. not using spotify.

Quiero añadir a un nuevo miembro, me pide que actualice mi dirección y me pasa exactamente lo mismo incluso cuando ingreso 2 caracteres, es desesperante y molesto.

Same thing is happening to me. The service it is calling is failing with a 500 error. The JSON returned is

{"code":500,"detail":"Service error"}

Same Here How can we get help?

A mi tambien me pasa lo mismo, alguien sabe si ya están trabajando sobre este error?

Também estou com o mesmo problema. Não consigo adicionar meu endereço. Já até copiei igualzinho esta escrito no Google Maps e mesmo assim não da certo. Espero que resolvam logo. Agradeço a atenção.

I have the same problem too 

Hello @dtnyctx@fero9226@wandersribeiro@Zabaes@lmorin and the rest,


Thanks for getting in touch!


We are aware of an issue where the address can't be found when trying to sign up for Family Premium and are currently investigating this.


Feel free to contribute in this topic where we gather information from affected users and keep everybody up-to-date. Be sure to comment or subscribe in the topic to get notifications. We'll get this sorted as soon as possible.


Sorry for the inconvenience. Let us know if you have further questions.


Have a nice day!

Are we going to know when it works properly?

Yesterday I had same issue using Chrome. Today I tried in Edge and was able to change it. Not sureif Chrome is working now.

Microsoft Edge worked for me!!! Yay! Thank you for that suggestion!

I am US military, stationed in Germany with a US postal address that will never be found on Google Maps.  Will there be a solution?

i'm having the same issue! 😞

Does not work on Samsung Web browser or Google Chrome I just signed up for a service I cannot use. You guys have a fix for this yet? Feel like we're all getting ripped off

me pasa lo mismo pero con el plan duo, ya llevo dos semanas en lo mismo y nada!!!!


Compre el pack hoy y pensé que se resolvería en una horas pero todavía me aparece lo mismo que a vos. Parece que es un problema que está hace varios días, como puede ser que no lo hallan arreglado.

Suggested posts