Address search not working


Address search not working

Casual Listener



My Question or Issue

I'm being prompted to add an address to continue using Premium Family.  When taken to the address page, the search feature is not working.  I get a message that it does not recognize my address just a few characters into typing. Even upon full completion of the entry, it still says it doesn't recognize it.  



Worked for me this morning - Chrome on Mac OS, US address.  Whether its fixed for good or not is unclear as the last update I saw was "working on it."  

28 Replies

Casual Listener

not working for me.. in fact it FINDS a variation of my address using google but then says its 'too vague' after i choose it ??? and to pick a building nearby?? how stupid.. i'm rural.. there is NO building 'nearby'.  Furthermore, google puts me in an entirely different town (as its crowd sourced info and some twit keeps 'correcting' the map to the town 5 km away).  So thanks to that, now it shows the 'wrong town', and the page doesn't even accept either my legal address or my postal address.  Furthermore... spotify HAS my address for billing purposes .. so why this nonsense??

oh i tried incognito


and it keeps saying "That address is too general. Try including a building number."

however there IS a house # there.. and a town, and a province and postal code, and country.


I am also being prompted to add my address, and then there is a pop up that says there was an error and to try again.


I logged in in Chrome, Firefox, and I cleared my cache, and still can't.

Anyone else have any ideas? I want to add my son to my family account that I'm paying for, but can't until this is done...I guess??


Community Legend

Hey @nbentley4,


Thanks for asking for help! 


Here's what you can try next:


  • Entering the address in an Incognito Window.
  • Doing it from a different device.
  • Another Internet connection. 
  • If the above don't work, wait 24 hours and try again.

Let us know how it goes! 

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.

Casual Listener
It's (still?) not working. I also got an error on my screen. Apparently this underlaying url is not available (HTTP 405 error): Any thoughts?
When I'm not logged in I get an authentication error, but that's not surprising.


Hey there @marinovdh,


Thanks for searching for the answer you need here!


You can ask the Premium Family plan manager to resend you an invitation link. If you get the same error, give it a go with a private/incognito browser or on another device. That should do the trick.


Hope you find this useful. Keep us posted how you get on.

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music is a language that doesn’t speak in particular words. It speaks in emotions, and if it’s in the bones, it’s in the bones.” - Keith Richards

Casual Listener

It's a bit annoying that something as simple as finding an address is getting errors these days. I'm a web developer myself so I know what can go wrong and how bad it is to deal with all kinds of situations like browser and physical locations.


The error I got was in Google Chrome and I also use several extensions with it. Incognito mode I already tried but didn't help. 

Just now I tried it in Microsft Edge and now it does work! Hooray. But after this I tried in Chrome again and IT ALSO WORKS??? This seems like a bugfix to me.


Anyway, it already cost me too much time now so I'll be fine wih it now. 


Hey there folks,


Thanks for your replies.


@ciara_belle, could you let us know if the address search is also working for you now or you're still experiencing issues with that.


If so, have you tried using Microsoft Edge like @marinovdh suggested?



Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“With freedom, flowers, books, and the moon, who could not be perfectly happy?” ― Oscar Wilde


me pasa lo mismo pero con el plan duo, ya llevo dos semanas en lo mismo y nada!!!!


Casual Listener
Intenta con edge


Compre el pack hoy y pensé que se resolvería en una horas pero todavía me aparece lo mismo que a vos. Parece que es un problema que está hace varios días, como puede ser que no lo hallan arreglado.


i'm having the same issue! 😞

Casual Listener

Yesterday I had same issue using Chrome. Today I tried in Edge and was able to change it. Not sureif Chrome is working now.

Casual Listener

Microsoft Edge worked for me!!! Yay! Thank you for that suggestion!

Spotify Legend

Hello @dtnyctx@fero9226@wandersribeiro@Zabaes@lmorin and the rest,


Thanks for getting in touch!


We are aware of an issue where the address can't be found when trying to sign up for Family Premium and are currently investigating this.


Feel free to contribute in this topic where we gather information from affected users and keep everybody up-to-date. Be sure to comment or subscribe in the topic to get notifications. We'll get this sorted as soon as possible.


Sorry for the inconvenience. Let us know if you have further questions.


Have a nice day!


This is completely unacceptable. You say you're aware of the problem, but you haven't done a single **bleep** thing to fix it. We're paying for this service. When are you going to get off your **bleep** and solve the issue?


Does not work on Samsung Web browser or Google Chrome I just signed up for a service I cannot use. You guys have a fix for this yet? Feel like we're all getting ripped off


I am US military, stationed in Germany with a US postal address that will never be found on Google Maps.  Will there be a solution?

Casual Listener
Are we going to know when it works properly?


I have the same problem too 


Também estou com o mesmo problema. Não consigo adicionar meu endereço. Já até copiei igualzinho esta escrito no Google Maps e mesmo assim não da certo. Espero que resolvam logo. Agradeço a atenção.