Can't update payment details for Spotify Premium, but I keep being offered Premium for Family?!

Reply
Highlighted

Can't update payment details for Spotify Premium, but I keep being offered Premium for Family?!

director212
Newbie

I need to change my card info to continue my $9.99 Premium subscription. The update payment details link keeps sending me back to the same page. However, it does allow credit card info to be entered on the $14.99 Premium for Family page. At worst, this seems like a deliberate attempt to get $5 more from people. At best, someone is really incompetent at repairing broken web links. This situation should have been resolved the first time a paying customer reported it last year. Yet, after many reports and complaints, it has still gone unresolved. I should not have to figure out a way to work around a difficulty your team created. After all, it's your job and your money. But I'm not giving you five dollars more for an upgrade I don't need. 

2 Replies

Re: Can't update payment details for Spotify Premium, but I keep being offered Premium for Family?!

ZullyB
Roadie

Hey @director212, welcome to the Spotify Community! 

 

Can you try to make the payment using a computer, different browser and incognito window? 

 

Also, remember to process the change here: https://www.spotify.com/family/.

 

We'll be waiting for your answer. 

 

Re: Can't update payment details for Spotify Premium, but I keep being offered Premium for Family?!

KarenR
Casual Listener

Like you, my 3 month trial was up and the first payment for Premium was successfully deducted from my account.  However, my card is now expiring so I tried to update my details - same problem as others have been reporting for months, nothing happens when you click.  I used the link, https://support.spotify.com/us/contact-spotify-support/ to chat with customer support, which was suggested by others on here.  I got an agent immediately and went through the same thing others have said about using different browsers (ridiculous), didn't work for me either.  However, after half an hour chatting with the agent, I got the message "Our technical team is aware of this issue and currently working on a fix. This is a priority for us, so hopefully it shouldn’t be long before you’re back up and running." and I've been told to try again in half an hour.  Based on the comments here, I'm not expecting magic.

SUGGESTED POSTS