Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Token provider returned the same token twice

Token provider returned the same token twice






(Desktop Pc)

Operating System

(Windows 10)


My Question or Issue

embedded playlists on my website stop playing after first song is finished, and in the console, this error is logged:

Uncaught (in promise) TransportError: Token provider returned the same token twice.
at n.value (


It is like this for almost a month.

10 Replies

Hey there, help's here!

Let's get right into this. Could you try loading this page in a different browser? Does the playlist stop playing after the first track as well? If possible, could you share the code (of the iFrame) you've published on your website? I'd love to take a closer look.

Have a good one,
HuboSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Hey Hubo, thank you for help.


It's same for all browsers with exactly same error message.


This is the iframe I use.


<iframe id="spotListBox" src="" frameborder="0" allowtransparency="true" allow="encrypted-media"></iframe>

I've also tried with another PC on same network and on a remote machine from another network. Same thing.

Have you fixed the issue?

I'm facing the same problem, although it worked completely fine last week.

There was a tall man from Cornwall, whose length exceeded his bed. ‘My body fits on it, but barely upon it, there’s no room for my big Cornish head!'

Same here. It seemed fixed during last week. Now same error has rised again

I was about to start hitting my head against the wall but it seems like it might be a bug on Spotify's end. 


When I hit the play button at the top of the embed straight away and try to play another track, nothing. However, if I hover over any of the other tracks in the album/playlist, and either hit the play button or click on another song, then it works. It's the strangest thing. 


Let me know if anyone else is able to reproduce this behavior!


I've attached screen recordings to help illustrate the point

Hey, having the same problem. Let me know if you can reproduce the problem like I did below!

Cool find.

However for me the issue presents itself no matter how I start the music.

Although yesterday it worked fine, but the same problem today.

Hope Spotify can identify the issue and fix it permanently soon enough.
There was a tall man from Cornwall, whose length exceeded his bed. ‘My body fits on it, but barely upon it, there’s no room for my big Cornish head!'

Hey folks, 


Thanks for bringing this up to our attention.


We can confirm that the right team looked into this and it should be fixed for everyone now.



Yes it is fixed. Thank you.

Suggested posts