Announcements

Web Playback SDK: only first 10 seconds of each song is played

Reply
Highlighted

Web Playback SDK: only first 10 seconds of each song is played

Newbie

Plan: Premium

Country: USA

 

Device: Samsung 2020 TV

Operating System: Tizen

 

My Question or Issue

I am developing an application on Tizen for Samsung TVs which I am attempting to integrate with Spotify.  I am using the Spotify Web Playback SDK and initiating playback using 

PUT https://api.spotify.com/v1/me/player/play

The issue I am experiencing is that the first song of my specified playlist plays for about 10 seconds, then there is no audio. 

 

If I programatically skip to the next song using:

player.nextTrack().then(() => {

  console.log('Skipped to next track!');

});

the next song plays for 10 seconds followed by silence.

1 Reply
Highlighted

Re: Web Playback SDK: only first 10 seconds of each song is played

Rock Star 16
Rock Star 16

Hey @gavm, thanks for coming to the Spotify for Developers board!

 

Hmm, thanks for letting me know about this! I'm afraid Tizen isn't currently supported by the Web Playback API. You can find all supported browsers/devices here: https://developer.spotify.com/documentation/web-playback-sdk/#supported-browsers.

 

If this is something you'd like to see, I recommend creating a new idea on the Spotify Community. That way, Spotify can keep track of it.

 

Feel free to give me a shout if you have any questions.

 

Have a good one,

Hubo

HuboRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
SUGGESTED POSTS