/v1/me/player/devices doesn't return Amazon Echo Dot devices (4th Gen)

/v1/me/player/devices doesn't return Amazon Echo Dot devices (4th Gen)

QAScenario

Plan 

Premium Family 

Country 

Brazil 

Device 

Amazon Echo Dot 4th Generation 

  

My Question or Issue 

Hey there, I've been having trouble with the /v1/me/player/devices endpoint. For some reason, all of the Amazon 4th Gen Echo Dot devices (and exclusively these devices) just stop being retrieved after some time.  

I did, however, notice that it's possible to use these devices via Connect on the Spotify app just fine (or on the web and desktop players, for that matter), which makes me think that this issue might be strictly API-related.  

Furthermore, I've also noticed that it's only after using the Spotify app and opening the device selection screen that the API starts retrieving the 4th Gen Echo Dot devices correctly.  

It's almost as if checking the user's available devices through the app emits a 'wake up' signal to the Echo Dot devices and only then makes them responsive to the API sweep. Is there such a thing?  

(Goes without saying, but I did try restarting the devices, linking and unlinking accounts, checking the firmware version, etc.). 

Thanks in advance! 

Reply
11 Replies

QAScenario

Hi, sorry for bumping this, but it seems that the issue is still occurring and unfortunately we haven't been able to figure it out. Would appreciate some help, thanks.

QAScenario

Hi, thanks for responding so quickly. I did check the topic, and while these issues (mine and theirs) might be related (in the sense that both refer specifically to the /player/devices endpoint), the issue I'm facing right now seems to be specifically pertinent to the 4th Generation Echo Dot, whereas the issue reported in the topic you mentioned seems to happen with any Echo Dot that has had its firmware updated.
Besides, the behavior reported at that topic seems to be slightly different from what I've been experiencing with the 4th Generation Echo Dot: instead of displaying the "weird" serial number as they've mentioned over there, my devices are simply not being retrieved.

Stephan1973

Are there any solutions?

what does the Spotify customer service say?

 

sinsys

Same issue over here. Thought I was going a bit mad until I found this thread. I have fourth gens and they keep disappearing. When I get them to register again they have UUIDs for names.

Stephan1973

I'm just wondering how long it will take Spotify to fix this **bleep**

the problem has been known for 6 months.

that's just annoying

ohej

Bumping to signal that we're looking into the issue. I'll post updated here as soon as we learn more.

QAScenario

The same thing reported by Stephan73 in the other thread happened to me now. I left the device powered off over the weekend and got the same response by the API when I tried getting the available devices this morning: even while offline (powered off), the device was still being retrieved and listed as if it were online and available.


Evidently some changes must've happened, since the previous behavior (device not being retrieved after a couple minutes) is not being shown anymore.

 

Moreso, I've also noticed that even if the device is powered on, I always get a 404 when trying to transfer the playback through the (...)/me/player endpoint (after 10 minutes or so of not playing anything in said device). So, the only difference really is the fact that now the device is always being listed by the API call, but still doesn't really work regardless.

 

This makes me wonder, do you mind giving us an update? Is this new behavior in any way an indication that you guys are trying to work around the issue presented here in this thread or is this an entirely new thing (bug)?

ohej

As you've noticed by the change in API behaviour, we are working on this issue and trying to get to the bottom of it. We identified and fixed some of the trouble, but it turns out to only be a part of a bigger puzzle that we're still investigating. 

 

I'll circle back when we have news.

QAScenario

Very happy to hear that. And you taking the time to keep us posted is sincerely very much appreciated.

If you don't mind, I plan on bumping this thread sporadically, no spamming, just to make sure that enough people are aware of this issue's current status. I say this because I think we can agree that a fair amount of users have been experiencing this problem for a while now and, like me, they eventually think about resorting to this board.

mvenus

Any news? This is an issue isnce the echo 4 was released. Really annoying unfortunately 😕

Suggested posts