Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Audi AMI and spotify

Audi AMI and spotify






iPhone 11 Pro

Operating System

iOS 13.3


My Question or Issue

I have been using my Audi music interface (AMI port to lightning cable) to connect my iPhone to my Audi A3 (2014) for a couple of years now. I chose to do this as the quality over Bluetooth is quite noticeable.


The AMI interface has been made for iPod so it does look for Apple Music or iTunes files however if you select Spotify before or after you connect it will work fine. I have done this for a while now with no issues. 

Since last week, spotify now does not show next track on my car interface. When it loads up, it shows a now playing playlist of the current track and the previous track. It will not skip to next track as there is no next track on the queue, even though it is on Spotify. Also when skipping tunes (via the phone) the album art, track details or anything doe not update like it used to. What has changed??


My spotify updated according to App Store a few days before it started doing this. I am currently on Version


Does anyone know how I can get it back to showing the now playing queue and displaying the correct information?


PS. The information on the lock screen on the iPhone is correct. It is only incorrect on the Audi screen.


Thank you 





8 Replies

I'm having the exact same issue on my 2012 Audi. Like you, it started with a Spotify update a few weeks ago. I'm not able to skip forward or see song information past the first loaded song. I've tried every setting in the app to get the playlist to load through the car but no luck.


It's very annoying and I hope it's fixed soon.

I am having the exact issue with my BMW IDrive screen. It started two updates ago. Until then it was working fine. No one from Spotify has even addressed this issue on these threads.

Any more updates anyone? Any fixes?


What has changed? Everything had worked so well until now!!

Mine is not fixed. There was an update or two. Nothing. Still beyond
annoying that a PAID service isn't working for weeks now.

I‘m facing the same issue since weeks and can‘t skip my tracks forward (but backwards is possible...) also like the others already wrote, the track info on the Display doesn‘t „update“ itself after the first track is played. Only disconnecting and reconnecting solves the issue with the wrong track information - but skipping isn‘t possible (which is a main feature and reason for Spotify Premium). 

Please investigate on this issue... it was working since I bought my car!

If there will be no fix, I will unsubscribe from Spotify Premium. 

Thank you in advance!

Any further update/fixes?

Hi all,


No updates unfortunately. 

One workaround I do is, I get a queue of two of the same track (whatever is currently playing on Spotify). When I select the track of the two that isn’t playing, it skips to the next song. However the album art for the duration of the journey will be the first track.


It is annoying but I just ignore the album art now On the Audi screen and end up using google maps with Spotify linked in on my


I use Apple podcasts and that works seamlessly with the Audi MMI as does Apple Music. 

The only thing I have looked at is the aftermarket upgrade to Airplay but that is at a cost of around £500 which I don’t think is worth it at the moment. 

On Audi Q7 (4M MMI), when switching to the next track, the cover art is not read and the progress bar freezes, but the sound continues to play. This does not depend on whether you switch the track yourself or just start playing the next track at the end of the previous one. If you switch to any other source, such as radio, and return back to Spotify, everything is restored, the cover appears and the progress bar starts from the right place. I have had this problem for over a year, at first everything worked as it should.

Suggested posts