Can't connect with mobile data

Reply

Can't connect with mobile data

Scully80
Casual Listener

Plan

Premium - family

Country

Austria (Provider drei)

Device

iPhone X

Operating System

iOS 13.1.3

 

My Question or Issue

Hello, I'm facing troubles with spotify for a week now. When I'm on a WiFi everything works fine, but the moment I'm using my mobile data, it says that I'm not connected to the internet. I can't search for songs, play any albums, only my downloaded playlists.
I've tried: deleting and reinstalling Spotify
switching off and on my phone, soft resetting it too

resetting all my network settings
turning airplane mode on, off, same with mobile data - but it still doesn't work.
Everything else works with my mobile data, I'm not in offline mode within spotify, mobile data usage is enabled for the app. Latest version of spotify is installed, and my phone is also up to date. I'm really at lost here. 😞 

14 Replies

Alex28030
Casual Listener

I've been having the same issue for weeks now, and I have tried everything that has been said before (loging out from all devices, reset all network settings, checking that mobile data is enabled for Spotify...)

I'm able to connect using WiFi, but not 4G mobile data. However I found out today that it works when I force my iPhone to use 3G mobile data.

Does anyone know if this is a carrier issue or a Spotify problem?


Thanks!

vamarul
Regular

@Alex28030 May I know which mobile network your are using?

Soumyagulati
Regular

Vodafone, India 

Rishikesh_Wagh
Visitor

Hi. I just solved this issue in my phone. Also, I found a way to play music even when the app wouldn't connect to mobile data. Sharing my experience below - 

 

I had been facing the same issue for days. Spotify worked on Wi-Fi but it just wouldn't connect to my mobile data (Vodafone). [Although I should mention that it WOULD sometimes randomly work on mobile data but that was very very rare and temporary]

I tried **bleep**ing everything -> re-installing, turning on data access, deleting cache, rebooting, turning off voice over LTE, ensured my mobile was running on the latest software update, allowed all app permissions and God knows what else.    

 

Now, after many a frustrating days, I did these two things simultaneously and one of them worked for me.  Idk which. 

 

1) I put it on and off airplane mode once 

 

2) Disabled the 'Always-on VPN' setting in my VPN app (SuperVPN).

Somehow even if you closed the app, the VPN stayed connected. I didn't notice this because the VPN symbol would also disappear when I closed the app so I would assume it isn't connected. But when I opened the general phone settings and checked the VPN option, it showed that the VPN is still connected. And this happened because the 'Always-on VPN' feature was enabled in my VPN app. Here's how to disable it (in my MIUI phone) - 

Settings —> VPN —> settings of the VPN app installed —> disable 'Always-on VPN' 

 

Attaching screenshots with this if possible. Between the airplane mode and the VPN I guess it was the VPN that worked for me but I'm not too sure. 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

OK, I was pretty lucky to get my Spotify working again but after days of tinkering around I had almost given up and accepted it as the new normal. Resorted to using **bleep**ing YouTube when outside. 🤦‍♂️

HOWEVER, I FOUND A WAY TO PLAY MUSIC EVEN WHEN IT WOULDN'T CONNECT TO MOBILE DATA. Here's how - 

 

When I would open my playlists, I couldn't play individual songs because obviously it wouldn't **bleep**ing connect to mobile data. BUT, if you hit 'Play' for the entire playlist, it will randomly play a song from it and if you then open the 'Que' you'll see all the songs from the playlist queued up randomly and now you can individually select a song from this 'que' and play it. Or you can just re-arrange the songs as per your liking. 

So, technically you can still play songs but you gotta hit play for the entire playlist first and then choose the songs from the que. 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Now, all of this worked for ME. I'm not sure if it'll work for you but you can certainly give it a try and let me know if it worked.

 

If my experience is helpful to even one equally frustrated poor music-loving bloke , then it will have been worth it. And it better be!! coz I had to faced some some really agonising and frustrating music-less days and also had to specially make a community account just to be able to type all of this out 😤

 

Screenshot_2020-09-05-22-15-42-615_com.android.settings~2.jpg
Screenshot_2020-09-05-22-16-19-400_com.android.settings.jpg

_sid
Casual Listener
I'm on Vodafone India too and almost 20 emails back N forth over last two days with spotify support staff nothing seems to work.

Mihail
Moderator
Moderator

Hey everyone,

Thanks posting here in the Community! We'll gladly help you out.

To keep everything in one place, we've summarized all troubleshooting steps bellow for case when Spotify can't connect over mobile data:

  1. Toggle Data Saver Mode in the setting menu on/off.
  2. Enable all permissions for the Spotify app. On Android phones this setting is found in Mobile Settings> Apps> Spotify, on iOS devices in Settings> Privacy >Spotify
  3. Try with a different network. For example if you're using 3G, try 4G and the other way around. It's a good idea to also reset your network settings and check if they have any restrictions in place.
  4. Perform a clean reinstall following these steps. Make sure to restart your device after removing the app. This is a simple, but often overlooked step. 

Hope you find this useful. Let us know how you get on.

MihailModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music is a language that doesn’t speak in particular words. It speaks in emotions, and if it’s in the bones, it’s in the bones.” - Keith Richards

Alex28030
Casual Listener

@vamarul I'm using Nova, in Iceland.

vamarul
Regular
Even I faced this issue for the past few days.Tried contacting Spotify support but they couldn't give a solution. after hours of trial and error I found out that it is carrier issue .The solution is to turn your 4G VoLTE off ( voice over LTE) In your mobile cellular settings. I dunno where is this setting in Android but it should definitely be there. On iPhone go to settings --> mobile data -->mobile data options -->voice&data --> select 4G,VoLTE Off. This is a workaround solution for now.

Anujmalhotra
Visitor
Ohhh u r legend u I did everything but this thing saved my life I love u to the core this thing will give u ur best night sleep just switch it to 4g bolte off in mobile data roaming

Przem_co
Visitor
Works!!! That is the one that works. @spotify you should fix this in the first płace, this optional Jas nothing to do with your services

Soumyagulati
Regular

I have the same issue, did you find a solution?

JeanneMarie
Visitor

I tried many things to get my spotify family premium to work on cellular data.  My husband and kids accounts (also on iPhones) never had a problem.  Finally I went to settings / general / and reset all settings.  I have wifi off, and it is working fine over cellular data connection.  1 hour on spotify chat and 20 minutes waiting for my phone's support line after trying almost everything I could think of to rectify the mysterious bug that would turn the cellular data toggle off on its own (only for spotify) didn't help until I read the right comment from someone else on this support string.  Thanks and I hope this help someone else!

Loxer
Rock Star 17
Rock Star 17

Hey @Scully80, welcome to the Community.

Hope you're doing great!

Could you go to Settings > Playback > Offline Mode and make sure it is off?

 

I'd also suggest using the Sign Out Everywhere and Remove Offline Devices options from your Spotify account page.

 

Thanks 🙂

LoxerRock Star 17
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

maggiewilson18
Newbie

I would recommend going to your iPhone Settings<Cellular Data<Spotify make sure that you have cellular data on for the app. 

SUGGESTED POSTS